WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7062 closed defect (bug) (invalid)

RSS-Feed Link not working with changed permalink structure

Reported by: christian_gnoth Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: rss feed permalink reporter-feedback
Focuses: Cc:

Description

Hello,
I have chenged my permalink structure from standard to "tag and name" and now the link for the RSS-Feed under the META Menu is no more working. The feed for the comments is working fine.

If I change back to the old permalink structure (standard) all is working fine.

I did the change, described in

http://trac.wordpress.org/changeset/7843

but still the same problem.

Change History (8)

comment:1 @christian_gnoth7 years ago

the error message:

Not Found

The requested URL /feed.xml/ was not found on this server.

comment:2 @DD327 years ago

  • Keywords reporter-feedback added
  • Priority changed from high to normal
  • Severity changed from major to normal

What is the permalink structure you are actually using?

There is no "tag and name" structure by default listed, so what are the custom fields you have set?

/feed.xml/

Can you check your template to see if the RSS feed is hard coded?

AFAIK there is no 'feed.xml' possible from the WP rss functions, and that error message looks like its produced by the webserver rather than WordPress, so it might not be even generating a url, and its just by chance that it works whne you revert?

comment:3 @christian_gnoth7 years ago

Hello,
I am using a german version of WordPress nd there is written in German "Tag und Name" - here the structure I am using:

/%year%/%monthnum%/%day%/%postname%/

Which template I have to check? Can you tell me the name of the file?

Yes it is working with the standard version of permalinks, then it works fine. What you mean, there is not feed.xml? I thougth WordPress generates feeds by themself.

I have exported the blog in feed.xml file which is in the base directory of the blog. But the message shows, that the file is searched in a subdirectory.

It can be, that there is somewhere this subdirectory hard coded, but i nwhich file I have to look? I found that the subdirectory /feed/ in which the feed.xml is expected is coded in the rewrite.php.

comment:4 @DD327 years ago

/%year%/%monthnum%/%day%/%postname%/

Ah ok, Translations can be a pain sometimes :)

Yes it is working with the standard version of permalinks, then it works fine. What you mean, there is not feed.xml? I thougth WordPress generates feeds by themself.

By that, I meant that WordPress doesnt create any feeds with the name 'feed.xml' as far as i knew, they're all /feed/ or /feed/rss/ etc.

Try changing to the default WordPress theme with that permalink setup, and see if the rss feed works then. If it does, Your theme's header.php file needs to be changed (not sure how right now, look at the <link rel="stylesheet" line), If the problem persists, then its a WordPress or plugin issue, If it persists after deactivating the plugins, then it'll definately be a WordPress issue. Just need to narrow down what is causing the problem for you.

comment:5 @christian_gnoth7 years ago

Hello,
I found the problem.

As I wrote, I have a feed.xml file (an export of the Blog-Content) in the base directory ( / ) from this blog.

Now I have deleted this file and it is working fine. Why WordPress is trying to open this file I do not know. Is this behavior correct?

This file was created through the export function.

What you mean, if you write the header is not correct? Is there a HTML syntax error?

comment:6 @christian_gnoth7 years ago

Hello,
apart from that problem, I have another problem with permalinks.

On my local computer I have installed apache as webserver and MySQL as database and wordpress. If I change the permalink structure to the one above I get a problem with all url's because the space in between the url is not correct kept.

normly the url looks like:

http://localhost:8510/SOB%20GmbH/wordpress/?p=123

with the changed permalik structure wordpress use this url:

http://localhost:8510/SOB20GmbH/wordpress/

the "%" is missing and therefore all url's are no more working.

comment:7 @christian_gnoth7 years ago

  • Cc christian.gnoth@… added

comment:8 @DD327 years ago

  • Milestone 2.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 2.5.1 deleted

Now I have deleted this file and it is working fine. Why WordPress is trying to open this file I do not know. Is this behavior correct?

Apache Rewrite only passes the query to WordPress if a file doesnt exist at the requested URL, It wasnt WordPress's Fault as it never recieved the request.

the "%" is missing and therefore all url's are no more working.

I cant reproduce it under Trunk(2.7) as of now, So i'm closing this ticket off as invalid.

Note: See TracTickets for help on using tickets.