WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7082 closed defect (bug) (fixed)

jQuery 1.2.5 crashes Safari 2.0.4

Reported by: tellyworth Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

It happens immediately after login, but not every time - say one in three logins.

Reproduced in trunk r8037. If I roll back to [7972] the crashes stop.

I can't find anything current in the jQuery trac that refers to a Safari crash.

Attachments (1)

hacked_makeArray.diff (490 bytes) - added by ryan 6 years ago.
Lame, ugly workaround for makeArray

Download all attachments as: .zip

Change History (13)

comment:1 ryan6 years ago

Started when [7973] bumped jQuery from 4663 (1.2.3) to 5623 (1.2.5). Persists with jQuery 5700 (1.2.6).

ryan6 years ago

Lame, ugly workaround for makeArray

comment:4 ryan6 years ago

(In [8043]) Hacked up version of jQuery to workaround Safari 2.0.4 bug. see #7082

comment:5 ryan6 years ago

(In [8044]) Add missing semi. see #7082

comment:6 ryan6 years ago

So much for my lame patch. It breaks theme preview. $(window).height() returns null.

comment:7 ryan6 years ago

(In [8046]) Revert jQuery hack. see #7082

comment:8 MattyRob6 years ago

  • Keywords reporter-feedback added

Are we using jQuery .2.6 yet? Does this still happen with the newer version?

comment:9 MattyRob6 years ago

  • Resolution set to invalid
  • Status changed from new to closed
  • No reporter feedback
  • WordPress is now using jQuery 1.2.6
  • Latest Safari release is now 3.1.2

Closing as invalid based on the above

comment:10 jacobsantos6 years ago

  • Keywords reporter-feedback removed
  • Milestone 2.7 deleted

comment:11 jacobsantos6 years ago

  • Milestone set to 2.7
  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:12 jacobsantos6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Marking as fixed since the revisions went into fixing it and no reporter feedback.

Note: See TracTickets for help on using tickets.