WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7143 closed defect (bug) (worksforme)

Plugin updater should obey minimum version

Reported by: Viper007Bond Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description

The plugin updater doesn't appear to obey the "minimum version" value for plugins, at least based on the source code.

For example, if a new version of a plugin requires WordPress 2.6, users running the older version of the plugin on WordPress 2.5 shouldn't be nagged to update.

Change History (2)

comment:1 follow-up: DD326 years ago

AFAIK this is taken care of server-side.

If a user is running 2.5, And a plugin requires 2.6, The update notification shouldnt even be sent to the WordPress installation.

Maybe this could be used in conjuction with #5117 to notify that a plugin requires a later version of WordPress?

comment:2 in reply to: ↑ 1 Viper007Bond6 years ago

  • Milestone 2.7 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Replying to DD32:

AFAIK this is taken care of server-side.

Ah, I wondered about that but decided to open a ticket just incase. :)

As for the notice, meh, if the user is gonna ignore the big "PLEASE UPDATE OMGZ!" message at the top of their screen, then I doubt they care about a plugin update.

Note: See TracTickets for help on using tickets.