WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#7182 closed defect (bug) (fixed)

feeds aren't canonical

Reported by: bubel Owned by: markjaquith
Milestone: 2.7 Priority: low
Severity: minor Version: 2.6
Component: General Keywords:
Focuses: Cc:

Description (last modified by lloydbudd)

Pretty permalink feeds aren't canonical.

ENV: WP trunk r8190 (2.6-beta1)
Browser: Firefox/3.0

The canonical URL for the feeds - both posts and comments - is not
working as intended. The following error only occurs with 'pretty'
permalinks enabled. My specific testing involved the "Day and name"
option.

The issue is evident when pointing your browser to "http://www.example.com/feed". The expected outcome is for the browser to display, upon load, the canonical URL, or
"http://www.example.com/feed/" Instead, the address bar will remain
populated with the address that you entered (i.e. no "/" added).

The issue is only evident with the feed URLs. For instance, pointing
your browser to "http://www.example.com/page" will yield the correct
outcome, and redirect to "http://www.example.com/page/". The same goes for categories, posts, etc.

Change History (7)

comment:1 @lloydbudd7 years ago

  • Description modified (diff)
  • Milestone changed from 2.6 to 2.7
  • Priority changed from normal to low
  • Severity changed from normal to minor
  • Summary changed from URLs of RSS Feeds Do Not Redirect Properly with Pretty Permalinks to feeds aren't canonical

comment:2 follow-up: @markjaquith7 years ago

  • Owner changed from anonymous to markjaquith
  • Status changed from new to assigned

TODO: make sure that a high percentage of feed readers follow 301 redirects.

comment:3 in reply to: ↑ 2 @Viper007Bond7 years ago

Replying to markjaquith:

TODO: make sure that a high percentage of feed readers follow 301 redirects.

If they don't, would not exit()'ing after sending the 301 solve the problem? That way the feed content is still there for readers that don't know what to do with the 301.

comment:4 @Otto427 years ago

Feedburner uses 301 redirects in their plugin.

301 is the recommended way to migrate feeds to new URLs.

comment:5 @scribu7 years ago

Possibly a duplicate of #4604

comment:6 @markjaquith6 years ago

(In [9156]) Canonical Feed URLs, first try. see #7182

comment:7 @matt6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Marking as fixed - seems to work great. Let's start new tickets for any bugs.

Note: See TracTickets for help on using tickets.