Make WordPress Core

Opened 7 years ago

Last modified 7 years ago

#7182 closed defect (bug)

feeds aren't canonical — at Version 1

Reported by: bubel Owned by: anonymous
Milestone: 2.7 Priority: low
Severity: minor Version: 2.6
Component: General Keywords:
Focuses: Cc:

Description (last modified by lloydbudd)

Pretty permalink feeds aren't canonical.

ENV: WP trunk r8190 (2.6-beta1)
Browser: Firefox/3.0

The canonical URL for the feeds - both posts and comments - is not
working as intended. The following error only occurs with 'pretty'
permalinks enabled. My specific testing involved the "Day and name"

The issue is evident when pointing your browser to "http://www.example.com/feed". The expected outcome is for the browser to display, upon load, the canonical URL, or
"http://www.example.com/feed/" Instead, the address bar will remain
populated with the address that you entered (i.e. no "/" added).

The issue is only evident with the feed URLs. For instance, pointing
your browser to "http://www.example.com/page" will yield the correct
outcome, and redirect to "http://www.example.com/page/". The same goes for categories, posts, etc.

Change History (1)

#1 @lloydbudd
7 years ago

  • Description modified (diff)
  • Milestone changed from 2.6 to 2.7
  • Priority changed from normal to low
  • Severity changed from normal to minor
  • Summary changed from URLs of RSS Feeds Do Not Redirect Properly with Pretty Permalinks to feeds aren't canonical
Note: See TracTickets for help on using tickets.