Make WordPress Core

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#7205 closed enhancement (wontfix)

Theme previewer needs an activate button

Reported by: johnbillion's profile johnbillion Owned by: westi's profile westi
Milestone: Priority: low
Severity: minor Version: 2.6
Component: Administration Keywords:
Focuses: Cc:

Description

The new theme previewer in 2.6 could have a slightly better UX. Currently there is no way to activate a theme with one click.

Two choices:

Either two buttons should be shown underneath each screenshot: [Preview] and [Activate]

or

Add an [Activate] button under each screenshot, and clicking on the screenshot shows the preview.

Change History (7)

#1 @johnbillion
14 years ago

  • Severity changed from normal to minor
  • Type changed from defect to enhancement

#2 @DD32
14 years ago

  • Milestone set to 2.7

#3 @thee17
14 years ago

What if clicking the title changed the theme, and the thumbnail opened the preview.

#4 @westi
14 years ago

  • Owner changed from anonymous to westi
  • Status changed from new to assigned

#5 @caesarsgrunt
14 years ago

I think the title vs thumbnail is too subtle and thus unintuitive.

I vote for two buttons/links below each theme.

#6 @matt
14 years ago

  • Resolution set to wontfix
  • Status changed from assigned to closed

I think you should always preview before activation. This is intended behaviour.

#7 @jacobsantos
14 years ago

  • Keywords needs-patch removed
  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.