WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7227 closed defect (bug) (fixed)

Undefined property in class-IXR.php

Reported by: wet Owned by: westi
Milestone: 2.7 Priority: lowest
Severity: trivial Version:
Component: XML-RPC Keywords:
Focuses: Cc:

Description

IXR_Date::$timezone is used, but never defined.

Attachments (2)

class-ixr.trunk.diff (4.8 KB) - added by jacobsantos 7 years ago.
Bringing IXR up to 0.7.1
7227.diff (1.4 KB) - added by ryan 7 years ago.

Download all attachments as: .zip

Change History (33)

comment:1 @Otto427 years ago

This is already fixed in version 1.7.1 of the library (we have 1.7). Might want to just get the newer one.

http://griffin.oobleyboo.com/files/xmlrpc/IXR_Library.inc.php.txt

More info here: http://griffin.oobleyboo.com/projects/xmlrpc/

comment:2 @josephscott7 years ago

  • Cc josephscott added
  • Component changed from General to XML-RPC

It may be worth getting back in sync with IXR:

http://code.google.com/p/ixr/

comment:3 @matt7 years ago

  • Milestone set to 2.7

comment:4 @westi7 years ago

  • Owner changed from anonymous to westi
  • Status changed from new to assigned

Would be good to see a patch to merge the newer IXR into WordPress

comment:5 follow-up: @jacobsantos7 years ago

It appears that WordPress has the newest version.

comment:6 in reply to: ↑ 5 @Otto427 years ago

Replying to jacobsantos:

It appears that WordPress has the newest version.

No, it doesn't. There's another version (1.7.1) which fixed that bug and which came out three days later:

http://griffin.oobleyboo.com/files/xmlrpc/IXR_Library.inc.php.txt

comment:7 @Otto427 years ago

My bad, wrong link. The one I linked to before was a modified one. This one is the original one, which has the same version number, but which also fixes that bug:

http://code.google.com/p/ixr/source/browse/trunk/IXR_Library.inc.php

@jacobsantos7 years ago

Bringing IXR up to 0.7.1

comment:8 @jacobsantos7 years ago

Patch brings class.ixr.php up to date.

comment:9 @jacobsantos7 years ago

Which in retrospect, is just removing the $this->timezone and changing the name of the library in the class.

comment:10 @ryan7 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [8376]) IXR 0.71. Props jacobsantos. fixes #7227

comment:11 @Nazgul7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

This undid the changes for #5666. Was that on purpose?

comment:12 @ryan7 years ago

Looks like that should be upstreamed.

comment:14 @jacobsantos7 years ago

When you said get it up to 0.7.1 I thought you meant literally. Sorry.

comment:15 @ryan7 years ago

(In [8377]) Revert accidental bits that snuck in with [8376]. see #7227

comment:16 @ryan7 years ago

(In [8378]) Resurrect 7615. see #7227

comment:17 @jacobsantos7 years ago

Seems fixed to me, now that the bits are fixed.

comment:18 @wet7 years ago

IXR 0.71 won't parse the ISO8610 time zone. This hasn't been beneficial in the past:
http://trac.wordpress.org/changeset/3279.

IMHO, removing the timezone member variable cures the symptom, not the cause, and this change set would break cross-time zone XML-RPC posting once again.

comment:19 @jacobsantos7 years ago

Damn it. Why use something totally screwed up like this? There are other XML-RPC libraries.

comment:20 @ryan7 years ago

What exactly is the original problem? That parseIso set timezone but parseTimestamp did not?

I'll comment these custom fixes with references to the corresponding tickets once we get everything straightened out.

@ryan7 years ago

comment:21 @ryan7 years ago

Patch resurrects timezone and comments all of our modifications.

comment:22 @santosj7 years ago

Your patch needs to add the timezone property to the beginning of the class or it won't fix the warning.

comment:23 @ryan7 years ago

(In [8403]) Add timezone var to IXR_date. Add timezone back to getIso(). Comment WP specific additions. see #7227

comment:24 @santosj7 years ago

Isn't this fix now?

comment:25 @pyadav7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:26 @pyadav7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:27 @pyadav7 years ago

  • Cc pyadav@… added; josephscott removed

comment:28 @pyadav7 years ago

  • Cc pyadav@… added; pyadav@… removed

comment:29 @pyadav7 years ago

  • Cc josephscott added; pyadav@… removed

comment:30 @jacobsantos7 years ago

Is this fixed yet?

comment:31 @ryan7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

I think so.

Note: See TracTickets for help on using tickets.