WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7240 closed defect (bug) (worksforme)

Saving drafts of pages with a parent prevents access of pages

Reported by: DD32 Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: Administration Keywords: needs-patch, reporter-feedback
Focuses: Cc:

Description

Reproduce:

  1. Create a new page having a non-default parent(Thats published)
  2. Click Save (Do not publish)
  3. Visit Manage Pages
    • Page shows you have a Draft Page.
  4. Filter to Draft pages only
  5. No pages will show in the table.

Unless you know the ID's of the pages, its impossible to access the edit page for them unless you unpublish the parent.

Change History (3)

comment:1 mrmist6 years ago

  • Keywords reporter-feedback added

Unable to reproduce this in 2.6

Anything special about the parent or child?

Tried with or without other unpublished Pages.

comment:2 DD326 years ago

Has indeed been fixed since i reported it, I can no longer reproduce it under trunk, I'll assume it was fixed in the 2.6 branch.

unsure of what to close this as.. Technically its fixed in 2.6.. Or maybe worksforme..

comment:3 DD326 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from new to closed
  • Version 2.6 deleted
Note: See TracTickets for help on using tickets.