Make WordPress Core

Opened 16 years ago

Closed 16 years ago

#7243 closed enhancement (duplicate)

PHPdoc effort for fixing @since tags for all WordPress inline documentation

Reported by: jacobsantos's profile jacobsantos Owned by: jacobsantos's profile jacobsantos
Milestone: Priority: low
Severity: trivial Version:
Component: Optimization Keywords: phpdoc
Focuses: Cc:

Description

Some functions might have incorrect @since tag version numbers, while other functions have missing version numbers to be filled in later. WordPress 2.7 should be that version, because the web application to retrieve that information won't be available until after the July 7th release.

Regardless, the version information should be filled out and should be accurate. This ticket serves as a reminder and placeholder for a ticket, which achieves this goal.

Change History (4)

#1 @jacobsantos
16 years ago

  • Cc jacobsantos added
  • Keywords phpdoc added

#2 @jacobsantos
16 years ago

  • Owner changed from anonymous to jacobsantos

#3 @jacobsantos
16 years ago

One note is that while functions and other WordPress coding is back ported, this does sort of throw off the since information. It should be assumed that if something shows up in a point release, that it was back ported and if it is found in the original release. The problem with this is that for some early WordPress releases, the time in between was much longer and the trunk might had been a point release.

There are several examples found for 2.1 that made their way in a point release of 2.0.x. Another problem is that not all of the WordPress releases are archived (I suppose for security reasons. This does throw off the accuracy a little bit.

Site will be at wp-version.dragonu.net and is currently incomplete.

#4 @jacobsantos
16 years ago

  • Cc jacobsantos removed
  • Milestone 2.7 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7550, fixes will be applied to that ticket, when finished.

Note: See TracTickets for help on using tickets.