Make WordPress Core

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#7290 closed defect (bug) (worksforme)

Multiple parallel 'new post's overwrite eachother

Reported by: sid3windr's profile SiD3WiNDR Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.1
Component: General Keywords:
Focuses: Cc:

Description

When you open multiple new post windows in several browser windows/tabs, they are apparently all editing the same post id in the database, which means whichever post is saved last is the only one showing up, all the others are lost forever.

I upgraded from 2.3 to 2.5, in 2.3 and below this was not a problem.

I presume, although I did not see it immediately, when opening a new "new post" page, the post id is coded into the html, and as long as nothing is saved as draft, opening another page will get the same id. Why not assign the id at the first save?

Change History (3)

#1 @error
14 years ago

Can't reproduce on 2.5.1. Opened 3 tabs and each Write Post screen in a new Firefox tab writes to a separate draft post in the database. If you are still experiencing this problem, please provide more detailed steps to reproduce.

#2 @SiD3WiNDR
14 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Argh, cannot reproduce anymore...

#3 @thee17
14 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.