WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7298 closed defect (bug) (invalid)

Gears Download Chokes on Flash (.SWF) File

Reported by: jeffreymcmanus Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Firefox 3, OS X 10.5.4

Just upgraded blog.jeffreymcmanus.com to WP 2.6, installed Gears, and WP tried to download all my WP stuff to the local machine.

It appears as if WP is trying to download some kind of Flash file (is this WP's Flash uploader component?) and Gears won't let it. Error message as follows:

Local storage status: Error: Download of 'http://blog.jeffreymcmanus.com/wp-includes/js/swfupload/swfupload_f9.swf' returned response code 404

Disabled Gears, restarted browser, same error message.

I'd suggest as a related usability issue on this, that telling the user to "disable Gears and try again" is OK (although it didn't work in my case), but I needed more information than "disable Gears" -- I just installed it for the first time two minutes ago and I had no clue how to disable it. Maybe say "disable the Gears browser plug-in" to distinguish it from some Wordpress admin feature?

Attachments (1)

gears-manifest.diff (1.1 KB) - added by scribu 6 years ago.
(svn version)

Download all attachments as: .zip

Change History (15)

comment:1 technosailor6 years ago

Jeffrey-

Hope you're doing well. Long time no talk!

Looks like that file doesn't exist on your server. Try uploading it manually to wp-includes/js/swfupload/

I wonder if there are any other files missing. Might want to reupload your 2.6 package.

comment:2 jeffreymcmanus6 years ago

Heya!

So if the file doesn't exist, why is Gears trying to download it? Shouldn't it be able to recover gracefully from a 404 here (maybe by just skipping the file)?

I used the Automatic Upgrade plugin to upgrade to 2.6, do you think the missing file could be a problem with that?

comment:3 hohohob6 years ago

I created a blank file named exactly like that .swf file. I tried Gears again, then it chokes of another .swf file in tinymce. My URL for that file is http://me.hohohob.com/wp-includes/'''js/tinymce/plugins/media/img/flv_player.swf

comment:4 hohohob6 years ago

Sorry, my url stuffed up. don't include those three .

comment:5 DD326 years ago

I think you're going to have to manually upload all the files, by the sounds of it, the Automatic upgrade plugin may've failed and not corrected installed everything.

Manually upload the /wp-includes/ folder and take it from there, see if Gears still complains.

comment:6 jeffreymcmanus6 years ago

I will give that a shot tomorrow. I think the bug is still legit, though -- it seems like the whole thing shouldn't fail just because it 404s on one file, and the directions it gives to the user when it goes tits-up could be a little clearer.

comment:7 DD326 years ago

, and the directions it gives to the user when it goes tits-up could be a little clearer.

I agree.. I dont use Gears at all (doesnt support my browser), But isnt it gears that needs to support the error conditions? I'm not sure..

comment:8 scribu6 years ago

The problem is not with the WPAU plugin, but with the gears-manifest.php

The following lines should be deleted

{ "url" : "../wp-includes/js/swfupload/swfupload_f9.swf" },
{ "url" : "../wp-includes/js/tinymce/plugins/media/img/flv_player.swf" },

scribu6 years ago

(svn version)

comment:9 scribu6 years ago

  • Keywords has_patch added

comment:10 scribu6 years ago

  • Milestone changed from 2.9 to 2.7

comment:11 DD326 years ago

The problem is not with the WPAU plugin, but with the gears-manifest.php

  • The specified files exist in 2.6
  • The Wordpress 2.6 release zip does include them. (Just confirming the release package was correct)
  • Gears supports flash files (AFAIK)
  • The server is returning a 404 therefor:
    • The reporters WordPress install is incomplete, The specified folder does not include the flash files (Comment 3 & See the net paragraph)

Compare: http://me.hohohob.com/wp-includes/js/tinymce/plugins/media/img/ to http://dd32.id.au/wordpress/wp-includes/js/tinymce/plugins/media/img/ and you'll notice a missing flash file.

Re-upload the files will fix it.

Those who like to delete files such as the TinyMCE files and/or flash upload files due to not liking using them, may edit the manifest manually to remove them if they want to use Gears.

Suggest closing as invalid due to above reasons unless theres something i've missed.

comment:12 jeffreymcmanus6 years ago

So, do nothing? You really think the correct behavior when one file is not found is for the whole thing to fail? Why? Why not just skip it and continue?

comment:13 DD326 years ago

You really think the correct behavior when one file is not found is for the whole thing to fail?

Not at all, However, AFAIK, Its Gears which produces the error, Not WordPress.

But remember: a missing file means a incomplete install, Why should WordPress work around an incomplete install?

The manifest could manually check that every file exists before sending the list, However, thats IO time consuming, The file is designed not to put any load on the server as its requested multiple times - If you can think of a better way?

I'd appreciate someone who has developed with Google Gears to chime in and set the record straight where the blame lies.

Same issue in support forums, Solved by correctly uploading files: http://wordpress.org/support/topic/189115

It appears this can be caused by the WordPress Automatic Upgrade plugin when running under Firefox with the FlashBlock plugin installed (According to that link)

comment:14 Otto426 years ago

  • Keywords has_patch removed
  • Milestone 2.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 2.6 deleted

If you're missing files, then that's the problem. Those files should exist, but they don't because you have upgraded incompletely. Simple.

This is an invalid bug. Upload ALL the files to your site.

Note: See TracTickets for help on using tickets.