WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7307 closed enhancement (wontfix)

Make Kubrik theme translatable

Reported by: msi08 Owned by:
Milestone: Priority: low
Severity: minor Version:
Component: General Keywords: kubrik theme translation
Focuses: Cc:

Description

I don't understand why the Kubrik theme is not translatable. The german guys here are doing a hard job to translate it for the german users. But this is not efficient, I think.

To be honest, I use another theme and I could say: I don't care. But I did take the time and I created a patch for all files of Kubrik. Let me know if you think it's useful or if I forgot something.

Attachments (4)

wp-default-theme.patch (38.5 KB) - added by msi08 6 years ago.
kubrik.r8701.patch (36.8 KB) - added by msi08 6 years ago.
kubrik.r8844.patch (36.0 KB) - added by msi08 6 years ago.
current version to reflect the latest changeset
kubrik.r9086.patch (34.4 KB) - added by msi08 6 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 msi086 years ago

OK, here is a newer version. After reading a post in a german blog saying "Comments Off" is not translated, I did use the last parameter in "comments_popup_link". This should fix the problem for Kubrik.

msi086 years ago

msi086 years ago

msi086 years ago

current version to reflect the latest changeset

msi086 years ago

comment:2 msi086 years ago

Hi guys, this is the last version of a translatable Kubrik, I will do. It reflects the current svn.

comment:3 matt6 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Kubrick is not going to be translated in core WP - there has been extensive discussion on this on the i18n lists and Nikolay can explain the thinking to you if you ask him.

comment:4 msi086 years ago

Yes, I would like to hear a good argument for that decision.

comment:5 jacobsantos6 years ago

  • Milestone 2.7 deleted

comment:6 huji6 years ago

Bug 7898 is closed as a duplicate of this bug. I'm interested to know where to find the long discussions about why not to "internationalize" (which is different from "trnsalte") the default theme. Can someone send a link or something to the discussions?

comment:7 DD326 years ago

I'm interested to know where to find the long discussions about why not to "internationalize" (which is different from "trnsalte") the default theme.

Correct me if i'm wrong, But Internationalizing a theme, involves allowing it to be translated.

You'll find the Discussion of the issue somewhere on the polyglots list, No idea where, but here's its archives: http://comox.textdrive.com/pipermail/wp-polyglots/

comment:8 follow-up: nbachiyski6 years ago

The long story short: the default theme isn't i18n-ed not to scare most of the theme authors. This probably won't change, so we have a i18n-ed version, which is regularly synced with WP:

http://svn.automattic.com/wordpress-i18n/theme/

comment:9 in reply to: ↑ 8 huji6 years ago

Replying to nbachiyski:

... not to scare most of the theme authors ...

Do you think theme authors would still get scared if we move forward and introduce an i18ned version of the default theme "togeather with" the non-i18ned version, bundled with the next releases of WordPress. This can be used as a transitional step.

... This probably won't change ...

I'd like to look into the other side of the coin "This probably will change" :)

comment:10 follow-up: nbachiyski6 years ago

Imagine you are a designer, with not much prior php knowledge and see sth like:

printf(__('This entry was posted %1$s on %2$s at %3$s and is filed under %4$s.', 'kubrick'), $time_since, get_the_time(__('l, F jS, Y', 'kubrick')), get_the_time(), get_the_category_list(', '));

There is a great chance you: 1. won't understand it, 2. try not to include text in your there or 3. don't bother making a theme at all.

In the current situation everybody is happy:

  1. Unexpereienced theme authors aren't daunted by complex stuff, just to include a message in the theme.
  2. Experienced theme authors still have a good example, from which to learn.
  3. Translators still have a i18n-ed version of the default theme.

comment:11 follow-up: msi086 years ago

I think you underestimate theme authors. If one is interested to make a theme, one will read the manuals and all the stuff. And even with a limited knowledge of PHP, one will understand a line like the line, you posted.

Just keep in mind that Kubrik is the default theme. I did use it while making the first steps with WordPress. I can just speak for the german users. Most users want to display the theme in their native language. They have to wait for an update of the german WP version. And what will happen with the automatic upgrade function in version 2.7? It would overwrite the Kubrik files if necessary. I personally do not think that this is a good idea.

I would really like to see that translated Kubrik version as a part of the regular installation.

comment:12 in reply to: ↑ 10 huji6 years ago

Replying to nbachiyski:
So by giving an "extreme" example, you make a judgement! Sorry if it sounds a bit harsh, but I can't agree with you Nikolay. The fact is, the solution to what you mentioned in the above example is not to forget about internationalization of Kubrik theme totally; the solution is to change the code a big (by adding a few variables, and writing in a nicer way) so that people with less experience can understand it better.

I again want to give you the example of MediaWiki. Unlike WordPress which uses, maybe around a 100-200 messages, MediaWiki uses more than 1200 messages in its core only (let alone the extensions) and many of them use parameters. These messages are mostly being translated by people who are not PHP developers, but they are translated very well using frameworks like http://translatewiki.net and the key is, complexity is avoided at coding time.

comment:13 in reply to: ↑ 11 ; follow-up: nbachiyski6 years ago

Replying to msi08:

Just keep in mind that Kubrik is the default theme. I did use it while making the first steps with WordPress. I can just speak for the german users. Most users want to display the theme in their native language. They have to wait for an update of the german WP version. And what will happen with the automatic upgrade function in version 2.7? It would overwrite the Kubrik files if necessary. I personally do not think that this is a good idea.

No, it won't get overwritten. Users will be able to upgrade to the localized version.

Unlike WordPress which uses, maybe around a 100-200 messages

2479, actually.

These messages are mostly being translated by people who are not PHP developers

The problem is with constructing the string, not translating them. WordPress is successfully translated by people, who don't know anything about PHP.

The current situation works well for everybody, who is either making themes or translating. Please try it first and then, if you have any problems, tell me.

comment:14 in reply to: ↑ 13 huji6 years ago

Replying to nbachiyski:

Unlike WordPress which uses, maybe around a 100-200 messages

2479, actually.

I'm talking about the default theme only, not the whole WordPress. It appears like there are less than 140 messages in the default theme, as of 2.6.2

The problem is with constructing the string, not translating them. WordPress is successfully translated by people, who don't know anything about PHP.

And the solution is to construct strings in a way that is easy to understand even for new comers. That is how projects like MediaWiki work.

The current situation works well for everybody, who is either making themes or translating. Please try it first and then, if you have any problems, tell me.

Okay; let's assume that I'm going to far here. But why isn't the i18n-ready default theme also included in the software, at least? This can help a lot.

Note: See TracTickets for help on using tickets.