WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7312 closed defect (bug) (worksforme)

upgrade.php should return to admin

Reported by: malfhok Owned by:
Milestone: 2.6.1 Priority: normal
Severity: normal Version: 2.6
Component: Administration Keywords: upgrade, return to admin
Focuses: Cc:

Description

The WordPress upgrade instructions ( http://codex.wordpress.org/Upgrading_WordPress_Extended ) tell the user to run the upgrade.php script, and then go update Permalinks and plugins in admin. But after running upgrade.php the user is sent to the home page of their blog, so they have to navigate back to admin to finish the WordPress upgrade. When finished running, the upgrade.php script should return the user to the WordPress Admin, not to the home page of the blog.

Change History (4)

comment:1 follow-up: ryan6 years ago

If upgrade is triggered from a visit to the admin, it redirects back to the referring admin page. This is how most people upgrade. We can change to redirect to admin instead of home if there is no admin referrer, but I don't know if it's worthwhile.

comment:2 in reply to: ↑ 1 malfhok6 years ago

Replying to ryan:

If upgrade is triggered from a visit to the admin, it redirects back to the referring admin page. This is how most people upgrade. We can change to redirect to admin instead of home if there is no admin referrer, but I don't know if it's worthwhile.

DId that just change in 2.6? Because in my last upgrade from 2.5.1 to 2.6, I triggered the upgrade from admin, and it redirected me to my blog home page, while according to what you said, it should be redirecting me back to admin. So apparently it doesn't quite work as expected.

comment:3 schmalenegger6 years ago

Hi,

i cannot reproduce this. Wordpress behaves exactly as ryan described it.

Can you please describe a bit more in detail when it happens to you?

schmalenegger

comment:4 MattyRob6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

If you login in to admin after upgrading your files the upgrade script will fire and then you'll be taken to the admin pages.

If you manually enter the URL of the upgrade script (domain/wp-admin/upgrade.php) then you will be returned to your home page. Note this is a manual upgrade not automated.

I would think that this is expected behaviour -therefore closing.

Note: See TracTickets for help on using tickets.