WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7313 closed defect (bug) (worksforme)

Editors authority on Administrator's content

Reported by: Coolkevman Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6
Component: General Keywords: role, publication, workflow
Focuses: Cc:

Description

Issue

Posts and static pages created by a user with Administrator role can't be edited by other users with Editor role.

Expected result

Users with Editor role and above (i.e. Editors and Administrators) should be allowed to edit any other post or page, including those created by other Editors (which is currently the case) but also those created by Administrators.

Question

Is this a bug a a feature ? :)

My opinion

I think Editors should be in charge of the whole publication workflow, which mean they should be able to act on the editorial content, edit it, unpublish it, republish it, etc. whoever the original author is. I see Administrators as normal Editors with all extra permissions required to do "technical" stuff (plugin managment, configuration, maintenance, ... and ultimately moderation within the Editor population).

Change History (5)

comment:1 ryan6 years ago

Works for me. Editors can edit Administrators.

comment:2 mrmist6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Agreed. Works for me too (editor can do everything they should be able to.)

comment:3 Coolkevman6 years ago

You're right. This works well with a fresh WordPress 2.6 installation.

But I'll investigate further as this issue is stilled affecting my legacy WordPress blog (migrated some weeks ago from 2.5.1 to 2.6).

comment:4 Coolkevman6 years ago

I found the source of my problem. It's not WordPress 2.6, so we can keep this bug closed.

FYI the problem described in this ticket was caused by the Exec-PHP 4.7 plugin.

comment:5 thee176 years ago

  • Milestone 2.6.1 deleted
Note: See TracTickets for help on using tickets.