WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7314 closed defect (bug) (duplicate)

Media Upload and invalid URLs

Reported by: Ziyphr Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6
Component: Administration Keywords: media uploader url image
Focuses: Cc:

Description

Was fine in 2.5. In 2.6 when you upload an image WP cannot show the thumbnails in the media area as it is always looking in wp-content/uploads/ even though in Settings -> Miscellaneous I have my folder set to wp-content/assets/.

Change History (5)

comment:1 ryan6 years ago

Looks like wp_upload_dir() is returning the right directory but the wrong URL for the case where "Store uploads in this folder" is set but "Full URL path to files" is not. It used to derive the URL from the path when the URL was not given, but now it falls back to the default content URL. As a workaround, try setting the "Full URL path to files" option to "http://your-blog.com/wp-content/assets/".

comment:2 ryan6 years ago

Note that the URL is stored with the attachment, so the links to images you've recently uploaded might remain broken even after you change the setting.

comment:3 mtekk6 years ago

This is related to #7305 and #7308.

comment:4 ryan6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Marking this as a dupe of #7308

comment:5 ryan6 years ago

  • Milestone 2.6.1 deleted
Note: See TracTickets for help on using tickets.