WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7322 closed defect (bug) (invalid)

Unable to login after 2.5.1 to 2.6 upgrade - returned to login screen.

Reported by: dolemite Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

After upgrading my site from (following directions as noted on the word press site) 2.5.1 to 2.6 I am unable to login to the admin section of the site. When credentials are entered, nothing happens. No 'sorry you used the wrong password' message, no redirect. It just stays on the main admin login page.

Now here's the kicker. If I go to the public face of the blog, I seem to be logged in but can access the site from a Safari for Windows browser. FF3 and IE 7 and IE 8 Beta do not work.

Not sure what else is needed. If someone would like to contact me I can show them my site.

Right now, I am unable to use Wordpress in a normal manner.

Change History (18)

comment:1 Otto426 years ago

Clearing your browser cookies will fix this issue.

The problem is that after an upgrade like this and you login, your browser gets the new admin cookie. But it has the same name as the old single login cookie, but with a new path. So there's some confusion about which cookie is which.

Clearing the cookies and relogging in eliminates the issue.

comment:2 mtekk6 years ago

I assume you checked in the support forums, cleared your cookies, and deactivated all of your plugins. If these resolve it, then close this ticket. If not...

There seems to be a problem when WordPress is not installed in the webroot (see http://wordpress.org/support/topic/188964/page/5), though 99% of the problems in that topic are from old cookies.

comment:3 dolemite6 years ago

Sorry that doesn't work. I have indeed leveraged the forums and they have not been any help. However, I have not see the new topic about wordpress not being installed in the webroot as my blog is. I'll look it over.

Here's what I have done with no success.

  • Cleared the Cookies out via the browser then tried again
  • Cleared the Cookies out via the browser then logged off and logged back in
  • Cleared the Cookies out via the browser then rebooted the machine and logged back in
  • I have used Crap Cleaner (ccleaner) to clean out the cookies of my Opera, Safari (for Windows), IE 7, IE 8, and FF 3 then tried again
  • I have used Crap Cleaner (ccleaner) to clean out the cookies of my Opera, Safari (for Windows), IE 7, IE 8, and FF 3. I then logged off and logged back in.
  • I have used Crap Cleaner (ccleaner) to clean out the cookies of my Opera, Safari (for Windows), IE 7, IE 8, and FF 3. I then rebooted the machine and logged back in.

comment:4 dolemite6 years ago

FYI that link noted doesn't help (http://wordpress.org/support/topic/188964/page/5). I have also tried deleting all of my plug-ins without any success as well. Trying to revert back to the previous version doesn't help at all either. I get the same bug.

comment:5 dolemite6 years ago

One more thing to add. Deleting my .htaccess file (to see if it's a re-direct issue) does not work.

comment:6 dolemite6 years ago

  • Summary changed from Unable to login to admin section after 2.5.1 to 2.6 upgrade to Unable to login to admin section after 2.5.1 to 2.6 upgrade - Wordpress not installed to root of website

comment:7 dolemite6 years ago

Ok I think I fixed it and the problem is two fold.

1) I had the Admin SSL Wordpress plugin enabled (current version). I deleted the plugin directory from the server.

Plugin page:

http://wordpress.org/extend/plugins/admin-ssl-secure-admin/

-Then-

2) I noticed I had the previous version of the wp-config.php with the single secret key enabled but not defined.

I looked over the following blog:

http://boren.nu/archives/2008/07/14/ssl-and-cookies-in-wordpress-26/

Removed the single secret key entry from the old version of the wp-config and added the following entries:

define('AUTH_KEY', 'put your unique phrase here');
define('SECURE_AUTH_KEY', 'put your unique phrase here');
define('LOGGED_IN_KEY', 'put your unique phrase here');

-and-

define(’FORCE_SSL_ADMIN’, true);
define(’FORCE_SSL_LOGIN’, true);

I uploaded the new version of the wp-config.php to the root of my blog (again in the sub directory of the root) and was able to login with no issues.


comment:8 dolemite6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 mtekk6 years ago

  • Milestone 2.6.1 deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 mtekk6 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:11 texassaluki6 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I am having the same problem where I get a 404 error when I try to access the login page

www.thenolands.com

comment:12 DD326 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

404's are not the fault of WordPress

Ensure the files have been uploaded, and that your .htaccess is correct.

If after checking those you do not succeed, Try the Support forums: http://wordpress.org/support/

comment:13 follow-up: jakkal6 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm still experiencing this problem, and I've updated the wp-config file as described above, cleared cookies, tried multiple browsers and tried the wp-login file from 2.5.1.

comment:14 in reply to: ↑ 13 Otto426 years ago

  • Priority changed from high to normal
  • Resolution set to invalid
  • Severity changed from critical to normal
  • Status changed from reopened to closed
  • Version 2.6 deleted

Replying to jakkal:

I'm still experiencing this problem, and I've updated the wp-config file as described above, cleared cookies, tried multiple browsers and tried the wp-login file from 2.5.1.

You should take your problem to the support forums, not here: http://wordpress.org/support/

comment:15 follow-up: trisweb6 years ago

  • Resolution invalid deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened
  • Summary changed from Unable to login to admin section after 2.5.1 to 2.6 upgrade - Wordpress not installed to root of website to Unable to login after 2.5.1 to 2.6 upgrade - returned to login screen.

Excuse me? This is not a support problem, several people have verified it and it is a bug introduced in 2.6!

I have the same exact problem that others have reported, and it has not been resolved by any "support" action - clearing cookies, different browsers, changing passwords, etc. etc. have not worked. The correct login credentials result in the login screen being shown over again with no error. Incorrect creds result in an error as expected.

I have a feeling this has to do with, oh, I don't know, the switch to a new login cookie system. There could be a bug somewhere in all that new code, so humor me.

I can open a new bug if this one is too different or old. Thanks.

comment:16 mrmist6 years ago

  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from reopened to closed

Countless people have upgraded. Some have experienced an issue. In almost every case this is a browser cookie/cache issue. In rare cases this is a local firewall issue.

comment:17 in reply to: ↑ 15 Otto426 years ago

Replying to trisweb:

Excuse me? This is not a support problem, several people have verified it and it is a bug introduced in 2.6!

No, it is not. It is a support problem. If it was a bug, then it would be a bug on more than a handful of cases. Yes, that is correct, a handful. Less than 50 people have reported the problem on the support forums, and 2.6 has been installed several thousand times.

The new login cookie system sets new cookies, however it also READS those new cookies. There is no bug there.

I have been able to duplicate the cookie problem through an unusual series of upgrade steps. However, clearing cookies solves that problem, every single time. This problem is characterized by the fact that using an alternative browser generally works.

It is also the case that some overprotective firewall and anti-virus systems running on the users local machine prevents the cookies from being set or cleared properly. In these cases, the solution is to fix the local machine.

I've yet to see a single case of a legitimate bug in this area. I did have one case where I could not immediately identify the issue, however before I could debug it further, the owner of the site erased it and reloaded and got it working that way. I suspect misloaded files in that instance.

See, a bug is not "it's broken for a bunch of people". A bug is "here is an error in the code at this specific location".

Until it is verified and can be duplicated reliably, it is not a bug. In that case, it is a problem that you are having... and those belong on the support forum.

When you have identified the cause or can give repeatable steps to duplicate it, then feel free to chime in here about it.

comment:18 trisweb6 years ago

Ok ok ok, chill out.

I apologize, my mistake. I disabled all plugins and was able to log in, so I'll enable them one-by-one and see where the issue is.

Sorry, and thanks.

Note: See TracTickets for help on using tickets.