WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7329 closed defect (bug) (invalid)

No visual view in post editor

Reported by: doranpalmer Owned by: azaozz
Milestone: Priority: normal
Severity: major Version: 2.6
Component: TinyMCE Keywords: reporter-feedback
Focuses: Cc:

Description

Unable to view the contents of the visual tab under a post edit, or creation, and am only allowed to veiw the html editor. I tried installing the latest version, as of the update it received five minutes after I upgraded WP from 2.6 beta 1 to 2.6RC1.

I am getting several errors as identified by IE7, they are as follows.

First Error-
line: 37
char: 154625
error: expected '('
code: 0
url: ../post-new.php

Next Error-
line: 85
char: 9
error: 'tinyMCE' is undefined
code: 0
url: ../post-new.php

Next Error-

line: 163
char: 34
eroor: unterminated constant string
code: 0
url: ../post-new.php

I have tried looking through it all and have found nothing that I could attribute to either the errors, or the problem I am having here. I have installed a fresh copy on my localhost with the same results. No steps are needed to replicate the problem, simply open the editor for a post, then what I see is that html is already selected, and I cannot change it to visual, clicking does nothing except make my browser point out the above errors.

I run the latest versions of IE7, XP SP3, on a broadband connection. I use the latest versions of both php and mysql, and since I have tested this on both my shared host and my own machine, for which I have ensured the latest updates have been installed, I am sure of these newest release only status.

I was using the first beta 2.6 released until around an hour ago. Everything else is smooth, but this problem provides that I can only add or edit content on my site if I feel like coding the html way every time. It is not what this software was meant to do, nor is what I chose this software for. Those are the reasons this problem should be looked at. Again, I tried, and will continue to try, to find any syntax errors or otherwise in the files.

Thanks

Change History (3)

comment:1 ryan6 years ago

  • Owner changed from anonymous to azaozz

comment:2 azaozz6 years ago

  • Component changed from Administration to TinyMCE
  • Keywords reporter-feedback added; posting admin visual editor html editor tinymce removed

Unfortunately the js error messages in IE7 are not helpful at all. From the first error (the only one that matters) it seems that an improper value was passed to TinyMCE.

There is a thread in the support forum that describes several steps to try and find the exact problem: http://wordpress.org/support/topic/165449

Also, deleting [siteurl]/wp-content/uploads/js-cache/ folder manually would force TinyMCE to refresh the cached file.

If the problems persist, a much more helpful error message can be produced by trying either Firefox or Opera.

comment:3 azaozz6 years ago

  • Milestone 2.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed

No reporter feedback in 3 months, problem was probably caused by stale cache.

Note: See TracTickets for help on using tickets.