WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7354 closed defect (bug) (duplicate)

Categories are not displayed correctly after sub-cat creation on Write => Post

Reported by: hailin Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: duplication, categories
Focuses: Cc:

Description

Write => Post, Categories, All Categories, Then start from a simple one eg: uncategorized, A

If one click "Add new category", then add A1 as child of A, then the display screws up. Complex ones make a bigger mess.

However, the hierarchy is displayed correctly in Manage=>Categories. So I think it's Ajax issue on the Write page

Change History (3)

comment:1 @mrmist7 years ago

  • Keywords duplication categories added
  • Summary changed from Categories are not displayed correctly on Write => Post to Categories are not displayed correctly after sub-cat creation on Write => Post

Agreed.

In fact it's even simpler than that.

If you add a sub-cat to any existing cat, then all the other lines are printed twice.

I guess it is some sort of bug in the loop that is used to display the sub categories (when a new one is added), so stuff is being pushed twice.

Possibly unrelated - There seems to be a further (connected?) flaw in that if you assign a sub-cat to a post and then edit the post, then the sub-cat is listed (with a tick) as though it was a major cat in the categories dialogue box.

comment:2 @mrmist7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Actually a duplicate of #6920.

comment:3 @thee177 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.