WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7362 closed enhancement (duplicate)

Browsers saving password creates annoyance when updating user profile

Reported by: aaron_guitar Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.1
Component: General Keywords: profile update password save
Focuses: Cc:

Description

In Firefox, if you have saved your login info and then try to update your profile, you must first clear the pre-populated "New Password" field. If you forget to, none of the valid changes will be saved because it gives a "passwords don't match" error. In my opinion, it should save the profile changes no matter if the passwords match or not. S
If the passwords don't match, save all the other data, leaving the password the same, and say "Changes saved, but the password wasn't updated." Since saving your passwords in your browser is common I imagine that I'm not the only one who finds this as an irritation.

Change History (4)

comment:1 mrmist6 years ago

I'm not convinced that this is an actual WP bug. The page is served with a blank box, FireFox chooses to fill the info in. IE7 does not, even if you have remembered the password. Nor does opera. It looks like a FF quirk to me.

comment:2 santosj6 years ago

  • Milestone 2.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Not a WordPress issue and yes it is annoying.

comment:3 aaron_guitar6 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I agree that it's not a WordPress issue but judging by the handful of tickets submitted about this, the fix I recommended would probably be appreciated.

comment:4 ninjaWR6 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

duplicate of #5006

Note: See TracTickets for help on using tickets.