WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7368 closed defect (bug) (invalid)

Unable to change category slug of Blogroll in new 2.6 installation

Reported by: mosey Owned by:
Milestone: Priority: normal
Severity: minor Version: 2.6
Component: General Keywords: blogroll, category slug, reporter-feedback
Focuses: Cc:

Description

This is my first ticket, so hope it isn't a boo boo! I did do a search for the 'blogroll' keyword, but couldn't find anything related to this issue.

I have just installed a brand new 2.6 version of Wordpress (for the first time, have worked with 2.1+) and am pretty sure that I could always change the category slug of 'Blogroll' to something else (like 'links') However, this doesn't seem to work for me on this new installation of 2.6

Thank you for reading!

p/s: If I try to change both the name and the category-slug at the same time, no changes occur. If I change only the name, the changes are applied.

Change History (8)

comment:1 @mrmist7 years ago

This works for me. (In manage - Link Categories)

I can change the Blogroll category name or slug or both.

comment:2 @scohoust7 years ago

Also works for me, make sure you aren't duplicating a slug - especially if you upgraded.

comment:3 @scohoust7 years ago

  • Keywords reporter-feedback added

comment:4 @mosey7 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the feedback and apologies for the late reply. I can confirm that it is indeed working, except for when I try to change the slug to 'wordpress' (which is what I was testing with in the first place) but as far as I can tell, I don't have any categories called 'wordpress' nor link categories, so am now a little confused!

comment:5 @mrmist7 years ago

Most likely you have a directory or other pre-existing real file called "wordpress" in your web structure. It won't let you change the slug to something that already exists.

Of course, you could say it would be nice to have an error message informing of this rather than just refreshing back to the main page.

comment:6 follow-up: @mosey7 years ago

Thanks for your reply, mrmist. I have checked my folders in both the Wordpress installation folder for the site, and also the root folder public_html (just in case) but didn't spot any file or folder with the 'wordpress' name, so I'm still quite baffled as well, especially as I've now tried it in on a local install, and it works fine, so apologies for the extra time.

Is it too late to say 'it would be nice to have an error message informing of this rather than jut refreshing back to the main page'?? :)

p/s: I forgot to mention before that it was a fresh installation of 2.6.

comment:7 in reply to: ↑ 6 @scohoust7 years ago

Replying to mosey:

Is it too late to say 'it would be nice to have an error message informing of this rather than jut refreshing back to the main page'?? :)

#7366 partially fixes this although as I said in that ticket the user still has no idea why the update failed. May look into improving it.

comment:8 @thee177 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.