WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7369 closed defect (bug) (duplicate)

Upload path need upload url path to work properly

Reported by: oncletom Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6
Component: Administration Keywords: upload, path, url
Focuses: Cc:

Description

I write my first post on WP 2.6 since the upgrade from 2.5.1. I did not have this problem before the upgrade.

Step to reproduce :

  • Admin > Settings > Miscellaneous > Upload Path : "images"
  • Admin > Settings > Miscellaneous > Upload Url Path : ""
  • Write > Post > Upload new media (flash uploader, 1 file or more), upload :
    • File is stored in the correct location (with its thumbnails) : blogpath/images/year/month/image.extension
    • Thumbnails & cie are displayed with blogurl/wp-content/uploads/year/month/image.extension

Step to fix the problem :

  • Admin > Settings > Miscellaneous > Upload Url Path : "blogurl/images"
  • Write > Post > Upload new media (flash uploader, 1 file or more), upload

Everything is fine since. But the previous picture won't display. Need to delete it, reupload.

I guess it's a bug somewhere in the code since 2.5.1.

Change History (1)

comment:1 @ryan7 years ago

  • Milestone 2.6.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7308

Note: See TracTickets for help on using tickets.