WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7398 closed defect (bug) (worksforme)

permalink problem in wp 2.6

Reported by: firezz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Hi to support team,

Regarding the issue from post

http://wordpress.org/support/topic/191423?replies=12#post-812716

could you advise on this case? as i have tried it and it doesnt work
some member here said they had tested it and it seems fine.
thanks

p-s in my same server, wp 2.5 , the permalink does work fine

www.nendoroiz.com

but the wp 2.6 is not working here

www.nendoroiz.com/rakyat

Change History (7)

comment:1 @mrmist7 years ago

  • Keywords reporter-feedback added

have you confirmed with your hosting provider that mod rewrite is enabled?

Do any of the pretty permalink solutions work?

comment:2 @mrmist7 years ago

  • Priority changed from high to normal

Demoting priority as this worksforme.

comment:3 @firezz7 years ago

hi mrmist ,

thanks for the reply, yupe, i have reconfirm with my hosting server's support and he siad it is being enabled already. In case, if that is the issues... why for my wp v2.5 i am able to use the permalink without any problem but not my wp v 2.6 ? all in the same domain name

www.nendoroiz.com - wp 2.5
www.nendoroiz.com/rakyat - wp 2.6

pls advise.
thanks

comment:4 @firezz7 years ago

  • Priority changed from normal to high

hi support team..

do u have any solution for this ?

comment:5 @DD327 years ago

  • Priority changed from high to normal

It appears your .htaccess is most likely not setup correctly.

Since visiting http://www.nendoroiz.com/rakyat/blahblah/ results in a Server Generated error and not a WordPress error, It means the server is not passing the request to WordPress.

Its generally .htaccess which passes it to WordPress, So I suggest rechecking it. (Possibly deleteing it, and letting WordPress re-create it).

comment:6 @firezz7 years ago

Hi support team, a new hosting and domain name i bought and it gives me same error msg,
same thing, i did reconfirm with the support team from my side, and everythg seems ok here, i am using wp 2.6 and i did not create any .htaccess

When i choose the "Month and name"
i am getting a reply here

If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

so now, what should i do with it ?
recreate a .htacess ?

pls advise
thanks

*p-s is the issues can be fixed if i upgrade it to 2.61 v ?

comment:7 @mrmist7 years ago

  • Keywords reporter-feedback removed
  • Milestone 2.7 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

You need to do what it says and create a .htaccess file in your hosting directory with the text you were given in it.

Then it will work. It's nothing to do with the wordpress version, it's because you do not have a writeable .htaccess file.

Note: See TracTickets for help on using tickets.