WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#7436 closed defect (bug) (fixed)

wp_nonce_ays()'s back link is broken

Reported by: Viper007Bond Owned by: westi
Milestone: 2.8 Priority: low
Severity: minor Version: 2.6
Component: Administration Keywords: reporter-feedback needs-patch
Focuses: Cc:

Description

If a nonce fails, the "Please try again." link on the error page is outputted incorrectly.

Here's what I got for example:

<p>Your attempt to edit this page: &quot;Page Title&quot; has failed.</p><p><a href='/wp-admin/page.php?action=edit#038;post=91'>Please try again.</a></p>

If you click that URL, you get a 404 due to the #038; presumably.

Change History (8)

comment:1 follow-up: DD326 years ago

If you click that URL, you get a 404 due to the #038; presumably.

The links invalid (Should have a n & in there), but a 404 shouldnt be raised, instead you should get "You attempted to edit a page that doesn't exist. Perhaps it was deleted?"

comment:2 in reply to: ↑ 1 Viper007Bond6 years ago

Replying to DD32:

The links invalid (Should have a n & in there), but a 404 shouldnt be raised, instead you should get "You attempted to edit a page that doesn't exist. Perhaps it was deleted?"

Yeah, that's what I get. Sorry, been a long day.

comment:3 westi6 years ago

  • Milestone changed from 2.6.1 to 2.6.2
  • Owner changed from anonymous to westi
  • Status changed from new to assigned

Is this still broken?

2.6.1 has been released, moving to 2.6.2 milestone

comment:4 follow-up: westi6 years ago

  • Keywords reporter-feedback added; needs-patch removed
  • Milestone changed from 2.7 to 2.8

Can you still reproduce this?

comment:5 jacobsantos5 years ago

  • Keywords needs-patch added

comment:6 in reply to: ↑ 4 Viper007Bond5 years ago

Replying to westi:

Can you still reproduce this?

I still get the "attempt to edit has failed" screen from time to time. I'll try and remember to check the nonce next time it happens.

comment:7 Denis-de-Bernardy5 years ago

I only ever got this once, when I tried to click save draft while the autosave was still running.

comment:8 ryan5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [11059]) Fix wp_nonce_ays() go back link. fixes #7436

Note: See TracTickets for help on using tickets.