WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7444 closed defect (bug) (duplicate)

sub-page structure broken by 2.5 update

Reported by: bitethemailman Owned by:
Milestone: Priority: high
Severity: major Version: 2.5
Component: General Keywords: permalinks uri htaccess broken slug
Focuses: Cc:

Description

Our permalink structure is as follows: site.com/info/%postname% for the front page blog, and site.com/%postname%/[child] and so on. We generate our links with wp_list_pages. In 2.3.2, these worked just fine. Now, a single top-level branch of our page hierarchy (oddly, however, not the rest of them) has been rendered useless. We think it has something to do with .htaccess, but also due to a suspicious-looking new array tucked away deep into wp_options, "page_uris". Changing the slug of the broken pages to something different or to the WP default numbering is a workaround, but changing it back broke it again. When a broken link is clicked on, the correct URL appears in the address bar but the parent page is still displayed (e.g., I'm on /parent and I click on the link for /parent/child, the url for /parent/child is in the address bar but I'm still looking at /parent). I've combed the bug database for clues but found nothing that seemed close to what is happening to us. any help!?

Change History (6)

comment:1 @bitethemailman7 years ago

  • Milestone set to 2.6.1

comment:2 @Otto427 years ago

Suspect this is a numeric-slug problem.

If so, mark this as dupe of #5305.

comment:3 @bitethemailman7 years ago

This is certainly possible. Our broken pages are links to pages about rooms in buildings, slugged as /building/room, where room is the 3 digit room number. Will confirm and change to dupe as necessary.

comment:4 @bitethemailman7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

All right, it looks to be a duplicate. One of the comments directly described what happens to me. In the meantime, we're just going to work around it.

comment:5 @Viper007Bond7 years ago

  • Milestone 2.6.1 deleted

comment:6 @Viper007Bond7 years ago

My plugin provides a workaround for this by trading in the ability to have paged Pages:

http://wordpress.org/extend/plugins/allow-numeric-stubs/

Note: See TracTickets for help on using tickets.