WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7481 closed defect (bug) (fixed)

Scheduled posts not being published

Reported by: johnhennmacc Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch tested commit
Focuses: Cc:

Description

The title probably says it all but I have been scheduling posts to be published in the future but they are getting stuck as scheduled. It takes manual intervention to release them from this state. Also, the date field shows the time since the publish time elapsed.

Attachments (2)

7481.r8522.diff (986 bytes) - added by santosj 7 years ago.
Fixes cURL for Cron in non-blocking mode. Based off of r8522, see #4779
7481.r8582.diff (818 bytes) - added by santosj 7 years ago.
Fixes cURL for Cron in non-blocking mode. Based off of r8582, see #4779

Download all attachments as: .zip

Change History (12)

comment:1 follow-up: @santosj7 years ago

Are you on the latest revision?

Do you have the HTTP Extension?

Do you have the cURL Extension?

What errors, if any, are being printed?

Might be caused by #4779.

comment:2 in reply to: ↑ 1 @johnhennmacc7 years ago

Replying to santosj:

Are you on the latest revision?

Yes

Do you have the HTTP Extension?

I don't have it on the web hosting that I use but I have now got it going on my home test system.

Do you have the cURL Extension?

Yes, I do

What errors, if any, are being printed?

No errors are seen unless the http extension was in place. Then, I started getting something like the following:

Warning: http_request() [function.http-request]: Timeout was reached; Timeout was reached (http://localhost/blog/wp-cron.php?check=[nonce string]) in [path to WordPress instance]/wp-includes/http.php on line 789

comment:3 @santosj7 years ago

Okay, if you have cURL, then the Cron will be using cURL to make the connection to the cron page. I'm not sure what is happening, but I can test it out on my system and see if it works for me and if not find where the problem is and fix it.

I haven't yet had any timeouts with the HTTP extension, but I'll look into that also.

comment:4 @santosj7 years ago

Oh yeah, this also has to do with #4779.

comment:5 @santosj7 years ago

HTTP extension works for me with no warnings or notices.

comment:6 @santosj7 years ago

The reason the cURL is not working is because curl_exec() has to run before anything is transferred.

@santosj7 years ago

Fixes cURL for Cron in non-blocking mode. Based off of r8522, see #4779

@santosj7 years ago

Fixes cURL for Cron in non-blocking mode. Based off of r8582, see #4779

comment:7 @santosj7 years ago

Can you test the patch and see if it works for you?

comment:8 @johnhennmacc7 years ago

Yes, the patch does the job and without any need for the http extension to be enabled.

comment:9 @santosj7 years ago

  • Keywords has-patch tested commit added

comment:10 @ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [8584]) Fixes cURL for Cron in non-blocking mode. Props santosj. fixes #7481 see #4779

Note: See TracTickets for help on using tickets.