WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 8 months ago

#7491 closed enhancement (duplicate)

thumbnail creation fails silently

Reported by: tieguy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upload Keywords: needs-patch
Focuses: Cc:

Description

When thumbnail creation fails, it fails silently, with no indication why it fails. That is a real pain in the ass if you're trying to debug. Frankly, I assumed for months that thumbnailing just wasn't implemented yet- it was only because I noticed that it does work on ma.tt that I even went back and tried to debug the situation.

I'm still not succeeding in actually getting the thumbnailing working, for what it is worth- extensive googling suggested I should install libgd, which I've now done, but no helpful errors from wordpress means I'm just back at square one in terms of figuring out why it is breaking.

There are no other directly pertinent bugs, but #7039 and #1952 mention instances of silent failure being a problem and #2794 has a (now bitrotted) patch creating an error reporting system.

Change History (8)

comment:1 jacobsantos5 years ago

You don't need libgd, you need the GD PHP extension.

comment:2 jacobsantos5 years ago

  • Component changed from General to Gallery
  • Keywords reporter-feedback added
  • Milestone changed from 2.7 to 2.8
  • Owner anonymous deleted

Thumbnails work for me, sending to next release since issue seems to be an edge case.

comment:3 Denis-de-Bernardy5 years ago

  • Component changed from Gallery to Upload
  • Keywords needs-patch added; reporter-feedback removed
  • Milestone changed from 2.8 to Future Release
  • Type changed from defect (bug) to enhancement

we could add a message, yeah...

comment:5 Denis-de-Bernardy5 years ago

  • Milestone changed from Future Release to 2.9

comment:6 ryan4 years ago

  • Milestone changed from 2.9 to Future Release

comment:8 helen8 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23127.

Note: See TracTickets for help on using tickets.