WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7508 closed defect (bug) (invalid)

8) is too common and shouldn't be made into a smiley

Reported by: lloydbudd Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: General Keywords: has-patch, tested
Focuses: Cc:

Description

This being 2008, I've seen quite a few 200[icon_cool.gif]. 8) is a much more common string than the other smilies.

ENV: trunk r8635

Attachments (1)

wp7508.diff (460 bytes) - added by lloydbudd 7 years ago.

Download all attachments as: .zip

Change History (7)

@lloydbudd7 years ago

comment:1 follow-up: @westi7 years ago

Would we not do better to enforce a space before?

comment:2 @DD327 years ago

Would we not do better to enforce a space before?

Isnt that what http://trac.wordpress.org/browser/trunk/wp-includes/functions.php#L2351 is supposed to do? (Mind you, I've not actually seen the code that replaces the smilies)

comment:3 @msi087 years ago

I did disable that string in my "functions.php". :cool: works good enough for me.

comment:4 in reply to: ↑ 1 @lloydbudd7 years ago

Replying to westi:

Would we not do better to enforce a space before?

Not completely confident, but still seems too likely (1 in 8) to accidentally smiley.

8-)

comment:5 follow-up: @ryan7 years ago

I can't reproduce this. 8) must be at the head of the line or be preceded by a space for it to be converted to a smiley.

comment:6 in reply to: ↑ 5 @lloydbudd7 years ago

  • Milestone 2.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Replying to ryan:

I can't reproduce this. 8) must be at the head of the line or be preceded by a space for it to be converted to a smiley.

Ugg, that fix was missing from wpcom. I must have mixed and matched my testing. I still think 8) is too common, but will close as invalid.

Note: See TracTickets for help on using tickets.