Make WordPress Core

Opened 7 years ago

Closed 9 months ago

#7580 closed enhancement (duplicate)

Use Exif description to autofill the caption

Reported by: mrmax Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6
Component: Media Keywords:
Focuses: Cc:


I test a lot of softwares to create a Exif description for my pictures.
Like "Exif Farm" or other kind of this softwares.
But When I Upload this picure in wp 2.6 the description will not show!
but i have some picture from the web, and when i upload them, wordpress show the description of it automatically in description Box!
like this picture:
and show description on it correctly:
Please tell me:
the problem is from Wp,
Or My software is not original?
So What should i do to show Description Exif Data in wp Correctly?

Change History (14)

#1 @Denis-de-Bernardy
7 years ago

  • Milestone set to Future Release
  • Priority changed from high to low
  • Type changed from defect (bug) to enhancement

based on phpdoc, for wp_read_image_metadata():

 * Get extended image metadata, exif or iptc as available.
 * Retrieves the EXIF metadata aperture, credit, camera, caption, copyright, iso
 * created_timestamp, focal_length, shutter_speed, and title.
 * The IPTC metadata that is retrieved is APP13, credit, byline, created date
 * and time, caption, copyright, and title. Also includes FNumber, Model,
 * DateTimeDigitized, FocalLength, ISOSpeedRatings, and ExposureTime.

#2 @Denis-de-Bernardy
7 years ago

  • Keywords needs-patch added

#3 @Denis-de-Bernardy
7 years ago

  • Component changed from General to Upload
  • Owner anonymous deleted
  • Summary changed from I have a problem with Exif Data In wp 2.6 to Use Exif description to autofill the caption
  • Type changed from enhancement to feature request

#4 @Denis-de-Bernardy
6 years ago

  • Milestone changed from Future Release to 2.9
  • Priority changed from low to high

#5 @ryan
6 years ago

  • Milestone changed from 2.9 to Future Release

#6 @hakre
6 years ago

Related: #9417

This ticket needs to be reviewed again I think exif data is reflected. I suggest to close as wontfix in the meantime.

#7 @hakre
6 years ago

Just reviewed again. Description should than be added to the list of metadata to retrieve from exif + after upload it should be checked for that value to fill the description field.

#8 @RanYanivHartstein
5 years ago

  • Cc RanYanivHartstein added

IPTC metadata can also be better handled.

Picasa saves image captions created by users in the IPTC Caption field. In Picasa, this is called "Make a Caption!".

However, when uploading these images, WP uses the IPTC Caption field for the Image Title field, and the Caption field remains empty.

Since Picasa is a very popular photo management tool, and since it the IPTC Caption field sounds like a good candidate for being used as an image caption in WP, I believe it would make sense to use data from the IPTC Caption field to auto-fill the Caption field on WP.

To reproduce this, use Picasa to add a caption to an image and upload that image to WP install. I was able to reproduce this on WP 3.0.

#9 follow-up: @Otto42
4 years ago

I made a quick plugin to fix this minor problem with Picasa captions a few months ago. Looks like the fields are just being used wrongly by WP to me.

Although different programs creating EXIF may be using them differently, so a wide variety of sample images with auto-generated EXIF information might be useful to get a feel of how the IPTC fields are actually being used by devices.


#10 @RDall
20 months ago

The confusion regarding IPTC field import is due to theInternational Press Communication Council (IPTC) calling the caption field a description field.

“A textual description, including captions, of the item’s content, particularly used where the object is not text.”

This explanation is page 13 of the IPTC Core Spec version 1 pdf http://www.iptc.org/std/photometadata/specification/IPTC-PhotoMetadata-201007_1.pdf

So I am guessing when WordPress Core decided import the IPTC meta data they mapped the Description Field to Description (in WordPress) and thus we have this confusion.

Most North American media organizations and some IPTC (or meta data) editors call this the caption field even though officially is called the Description field as it describes the photo.

I'd put a +1 on making this change in the next release.

This ticket was mentioned in IRC in #wordpress-dev by RDall. View the logs.

19 months ago

#12 @ericlewis
18 months ago

  • Component changed from Upload to Media

#13 in reply to: ↑ 9 @ericlewis
18 months ago

Replying to Otto42:

I made a quick plugin to fix this minor problem with Picasa captions a few months ago. Looks like the fields are just being used wrongly by WP to me.

Picasa now takes the "caption" in Picasa and maps that to the title field in EXIF data. I don't believe anything maps to the EXIF caption field via Picasa now.

Maybe we can do something like a fallback here. Set the caption in WordPress to caption in EXIF data. If that's not set, try the title.

Spoke too soon, this is due to the way we normalize EXIF data, see my comment here.

Last edited 18 months ago by ericlewis (previous) (diff)

#14 @SergeyBiryukov
9 months ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Priority changed from high to normal
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from feature request to enhancement

Duplicate of #22768.

Note: See TracTickets for help on using tickets.