WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7596 closed defect (bug) (worksforme)

Categories area in admin interface loads a div that looks like it is an iframe of that page, then page reloads

Reported by: amoswright Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6.1
Component: Administration Keywords: reporter-feedback
Focuses: Cc:

Description

When editing a post, usually (though not every time) the categories selection area load a div that looks like an iframe of the current admin page. see screenshot at this url:
http://web11567.aiso.net/wordpress-category-bug.png
when this happens, after several seconds, the whole page refreshes, and loads a page that looks like this screenshot:
http://web11567.aiso.net/wordpress-category-bug2.png
i.e. it is just some of the editing buttons, and nothing else.
The problem is occuring for me using FF 3.0 on Ubuntu 8.04.
I have found that disabling javascript fixes the problem. I have tried disabling plugins, but this does not fix the problem. I tried downgrading from my current wp 2.6.1 to wp 2.6, but this did not fix the problem either (I'm not sure when the problem arose, this install is mostly pages so post editing (where the problem occurs) is infrequent. Finally, I also tried a clean install of wp 2.6.1, and the problem still occurred. I have not successfully found other references to this problem by googling, so perhaps it is rare, or specific to my platform or the server that it is on (hosted on aiso.net, which runs some unspecified flavor of linux). It may be the server, b/c I can edit another site with wp 2.6.1 on my ubuntu box without the problem occurring.

Change History (7)

comment:1 follow-up: @azaozz7 years ago

  • Keywords reporter-feedback added

Looks like js error. TinyMCE is not loaded in the first screenshot either. Could you install Firebug and see what's the first error.

comment:2 in reply to: ↑ 1 @amoswright7 years ago

Replying to azaozz:

Looks like js error. TinyMCE is not loaded in the first screenshot either. Could you install Firebug and see what's the first error.

I have Firebug installed - and it has thrown errors on the site previously, but it is not showing errors now. Am I correct in thinking that firebug shows a little red icon to indicate errors? or is there somthing else I need to do to "debug"?

Frustratingly, the problem is intermittent - it can appear, then dissapear on refresh, and visa-versa. Either way, I am now not seeing js errors currently, even when the problem occurs. Also, the problem can occur while TinyMCE is loaded.

I realize that this is not giving you much to go on, especially if nobody (or not many) else is reporting this problem. Thank you for looking into it. I will be using the site regularly and will check back again in a day or so with an update.

Thank You, Amos.

comment:3 follow-up: @azaozz7 years ago

To see the errors, make sure the Console tab in Firebug is enabled. Can also see them in Firefox' Error Console (set it to show only js errors). Perhaps try disabling both disk and memory cache in FF and see if there's any difference.

comment:4 in reply to: ↑ 3 @amoswright7 years ago

Replying to azaozz:

To see the errors, make sure the Console tab in Firebug is enabled. Can also see them in...

Thanks for the instructions - Firebug is showing 5 js errors:

tinymce is not defined
[Break on this error] tinymce.PluginManager.requireLangPack('NextGEN');
editor_p...s?ver=311 (line 5)
tinymce is not defined
[Break on this error] <!DOCTYPE html PUBLIC "-W3CDTD XHTML.../TR/xhtml1/DTD/xhtml1-transitional.dtd">
post-new.php (line 1)
jQuery is not defined
[Break on this error] <link rel='stylesheet' href='http://web1...er=2.6.1' type='text/css' media='all' />
post-new.php (line 13)

jquery.j...ver=1.2.6 (line 11)

jQuery is not defined
[Break on this error] <script type='text/javascript' src='http...js/jquery/jquery.js?ver=1.2.6'></script>
post-new.php (line 18)

jquery.j...ver=1.2.6 (line 11)

jQuery is not defined
[Break on this error] previewPostText: "Preview this Post",
post-new.php (line 36)

Does this give any indication?
Thank you again for your help.
Amos.

comment:5 @azaozz7 years ago

Both TinyMCE and jQuery not loaded? Few things to try: look at the Net tab in Firebug for any missing (red) files; try accessing directly the js files to see if anything is prepended/appended; try another computer/OS/browser; disable all plugins and switch to the default or classic theme.

comment:6 @thee177 years ago

  • Milestone changed from 2.0.12 to 2.6.2

comment:7 @ryan7 years ago

  • Milestone 2.7 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Haven't seen other report of this. Closing pending reporter feedback.

Note: See TracTickets for help on using tickets.