Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 5 months ago

#7608 closed defect (bug) (duplicate)

Trouble with link categories and tags naming

Reported by: oyvindmal Owned by:
Milestone: Priority: high
Severity: critical Version:
Component: Administration Keywords:
Focuses: Cc:


If I make a link category called e.g "Football" and then later on tag a post with the tag Football. Then later on if I decide to change the name of the link category the name of the tag is also changed.

I think this has a really simple explaination. The query which changes the name only ueses where name=$category_name (not sure about the field names and variablenames) and therefore will change all occurances of $category_name. Instead it would be better to use $category_id at that should be an unique identifyer for the category/tag.

Change History (2)

comment:1 @ryan7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

See #6211. Canonical names across all taxonomies is by design, at least for now.

comment:2 @DrewAPicture5 months ago

  • Milestone 2.6.2 deleted
Note: See TracTickets for help on using tickets.