WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7620 closed defect (bug) (fixed)

Admin Footer overlaps other content in some browsers

Reported by: caesarsgrunt Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

Caused by negative top margin. Patch attached. Only tested in Safari and Firefox.

Attachments (3)

7620.diff (307 bytes) - added by caesarsgrunt 7 years ago.
Remove negative -75px top margin on #footer
7620.2.diff (307 bytes) - added by caesarsgrunt 7 years ago.
Remove negative -75px top margin on #footer
7620.3.diff (303 bytes) - added by caesarsgrunt 7 years ago.
Possibly better patch, still hopefully temporary…

Download all attachments as: .zip

Change History (12)

@caesarsgrunt7 years ago

Remove negative -75px top margin on #footer

@caesarsgrunt7 years ago

Remove negative -75px top margin on #footer

comment:1 @azaozz7 years ago

That would make short pages to always have a vertical scrollbar, in all browsers. There are other glitches with short pages too, the base layout needs fixing in general.

comment:2 @caesarsgrunt7 years ago

  • Keywords needs-patch added; has-patch needs-testing removed

Yes, you're right, sorry. I'll have another look and see if I can come up with another fix.

Actually, I always have had a vertical scrollbar on short pages, which scrolls just a few pixels. It irritates me, though it's true that it means the page doesn't jump horizontally. Setting overflow-x: scroll; overflow-y: hidden; is a nicer solution in those browsers which support it, IMO, since the scrollbar is then disabled on short pages.

comment:3 @caesarsgrunt7 years ago

BTW - not relevant to this ticket, but...
This is the second path I've had which has appeared a second time a few minutes after I uploaded it, even though after the successful first upload I look at the page and only one is there, and then I go away, losing the tab altogether. I had a trac ticket created twice yesterday, too.

comment:4 @caesarsgrunt7 years ago

  • Summary changed from Admin Footer overlaps Dashboard secondary feed (Planet Wordpress) widget in Safari to Admin Footer overlaps other content in Safari

Seems it applies to all other long dashboard pages, too.

comment:5 @DD327 years ago

Got the same issue in Opera 9.52 here. Applying that patch fixes it for Opera too.

comment:6 @DD327 years ago

  • Keywords has-patch added; needs-patch removed

comment:7 @caesarsgrunt7 years ago

  • Summary changed from Admin Footer overlaps other content in Safari to Admin Footer overlaps other content in some browsers

This second patch may be better - doesn't cause scrollbars on short screens.

Tested in :

  • Firefox,
  • Safari,
  • Opera (in which there are other bugs in the footer too, BTW),
  • IE 7 (Yuck. Has a horizontal scrollbar...)

Didn't cause any problems in any of the above. Caused a slight gap below the content on long pages in IE, and a 75px gap in Fx - but I don't think these really matter.

Try it out, people...


Note :
The whole admin CSS needs redoing really, IMO. (Help, Dean J Robinson!)
It would be nice to cut out the JS which lengthens the page on short pages, somehow. I'll look at how Fluency does it.

@caesarsgrunt7 years ago

Possibly better patch, still hopefully temporary...

comment:8 @azaozz7 years ago

The js that stretches the page was a temp fix for Crazyhorse (like some other places). You're right, the base css needs redoing, the IE css too. It has to be fluid both horizontally and vertically.

comment:9 @azaozz7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [8785]) Base css layout, fixes #7620

Note: See TracTickets for help on using tickets.