WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7630 closed defect (bug) (fixed)

Easy to lose draft post if logged off for some reason

Reported by: lloydbudd Owned by:
Milestone: 2.7 Priority: high
Severity: critical Version: 2.7
Component: General Keywords: needs-patch
Focuses: Cc:

Description

Easy to lose draft post if logged off for some reason

ENV: WP trunk r8759

I had written my greatest post ever. Clicking publish, I found myself staring at the login page. I don't know what that happened, but I think that is the lesser issue.

It's easy to reproduce by manually logging off while writing.

If logged out while writing an article:

1) the feedback, if any, when auto-save fails sucks. We need to help the person preserve their work

2) After clicking Save/Publish and logging back in, my work is gone. Using the Firefox 3 Back button returning to wp-admin/post-new.php I'm crying because of the blank page that confronts me.

Attachments (2)

patch_autosave_8941.diff (1.3 KB) - added by tott 6 years ago.
simple feedback patch wp-admin/admin-ajax.php
autosave_alert.jpeg (23.6 KB) - added by tott 6 years ago.
screenshot of notice

Download all attachments as: .zip

Change History (5)

comment:1 caesarsgrunt6 years ago

  • Keywords needs-patch added
  • Summary changed from Should help Easy to lose draft post if logged off for some reason to Easy to lose draft post if logged off for some reason

tott6 years ago

simple feedback patch wp-admin/admin-ajax.php

comment:2 tott6 years ago

I attached a simple patch to provide feedback within the autosave message. maybe something more obvious needed.

The most obvious attempt to save the data would be storing it in a session and set a cookie. After login this cookie could be used in edit post page to recover the post and procude a draft.

tott6 years ago

screenshot of notice

comment:3 azaozz6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9216]) Show warning if user is logged out while writing or editing, includes patch by tott, fixes #7630

Note: See TracTickets for help on using tickets.