WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#7631 closed defect (bug) (worksforme)

Saving a post causes WP to hang

Reported by: theamazingrando Owned by:
Milestone: Priority: high
Severity: normal Version: 2.6
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

I recently upgraded to 2.6. Now, when I hit 'Save' after creating/editing a post, it gets saved, but wp hangs completely trying to load the page after that ("Changes saved, continue editing or go back"). I can't go to any other pages while wordpress is in this state, and have to restart my web server (lighttpd).

Specifically, its this request that hangs:

GET /blog/wp-admin/post.php?action=edit&post=25&message=1&_wp_original_http_referer=http%3A%2F%2Fwww.theamazingrando.com%2Fblog%2Fwp-admin%2Fedit.php HTTP/1.1" 200 35651 "http://www.theamazingrando.com/blog/wp-admin/post.php?action=edit&post=25

I'm able to access other pages served by lightty, only wp-related pages won't load. This also worked fine before I upgraded from 2.5.

Additionally, I just upgraded to 2.6.1, and creating a new post seems to work, but saving changes to an existing post causes the issue. The changes get saved, but I have to restart lighttpd before I can view and wp pages again.

Change History (5)

comment:1 CyberCr33p6 years ago

I have the same problem with 1 blog. Lighttpd 1.4.19, php 5.2.6 running as fastcgi, freebsd 7.0.

comment:2 CyberCr33p6 years ago

  • Priority changed from normal to high

I think the problem is related with Javascript. If I disable Javascript then php doesn't hang.

comment:3 CyberCr33p6 years ago

  • Keywords hang edit added

I tried FCKEditor instead of TinyMCE and didn't fix the issue.

comment:4 azaozz6 years ago

  • Keywords reporter-feedback added; hang edit removed

Could you look in the server logs to see exactly what's happening? Also perhaps try disabling some of the js to narrow it down.

comment:5 ryan5 years ago

  • Milestone 2.7 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing as worksforme. Reopen with requested information.

Note: See TracTickets for help on using tickets.