WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 3 years ago

#7634 closed enhancement (invalid)

Need a way to cancel an upload edit

Reported by: markjaquith Owned by:
Milestone: Priority: normal
Severity: major Version: 2.7
Component: Upload Keywords: ux-feedback
Focuses: Cc:

Description

When you click a media upload, you have to either save it, or use the back button in the browser. Feels like a dead end.

Change History (16)

#1 @budde
10 years ago

  • Type changed from defect to enhancement

#2 @ryan
10 years ago

  • Milestone changed from 2.7 to 2.8

Moving enhancements to 2.8.

#3 @FFEMTcJ
9 years ago

  • Keywords needs-patch added
  • Milestone changed from 2.8 to Future Release

#4 @Denis-de-Bernardy
9 years ago

  • Component changed from Administration to UI
  • Keywords 2nd-opinion added
  • Owner anonymous deleted

Agreed. :-)

#5 @Denis-de-Bernardy
9 years ago

  • Keywords 2nd-opinion removed

#6 @Denis-de-Bernardy
9 years ago

  • Milestone changed from Future Release to 2.9

#7 @Denis-de-Bernardy
9 years ago

  • Component changed from UI to Upload

#8 @janeforshort
9 years ago

  • Milestone changed from 2.9 to Future Release

Since the media UI redux got bumped, bumping this with it.

#9 @johnbillion
7 years ago

  • Keywords needs-patch removed
  • Resolution set to worksforme
  • Status changed from new to closed

Not sure if this ticket applied to the inline media manager or the main Media screen. Either way, editing a media item now displays a 'Cancel' button as of 3.1.

#10 @dd32
7 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Still applies to the Media Edit page.

Steps to Reproduce:

  1. On the Media library list page click "Edit" in the actions
  2. Modify a field
  3. Admire "Update Media" button and no cancel (Other than browsers back button)

#11 @johnbillion
7 years ago

Hmmm. How is that behaviour any different to editing any other object such as a post, link, user, or comment? No other editing screen has a 'Cancel' button, why would the edit media screen have one?

#12 @dd32
7 years ago

  • Keywords ux-feedback added

No other editing screen has a 'Cancel' button, why would the edit media screen have one?

Not sure myself, Eitherway, I re-opened based on the fact that IMO the ticket still applies.

Marking as ux-feedback for this however

#13 @janubande007
5 years ago

  • Severity changed from normal to major

Really, you guys have not yet figured out a way to "Cancel" a file upload even after 4 years? This is stuff should have been done 10 years ago!

I'm using WP 3.5 and still there no way to cancel a media upload, ANYWHERE in Wordpress when editing/creating a post, period.

Also a quick & dirty way to select multiple media files attached to a post (when "editing" the post) and delete them would really be usefull, currently its a pain to try an locate it in Media manager.

#15 @nikolov.tmw
3 years ago

I could argue that this should be a wontfix. This particular media edit view is not really much different than editing any other post and if we're going to add a cancel button here, then why not add it to the other pages?

In case it's still valid, then here are a few questions that come to my mind:

How would we determine where the user is coming from? Should we just send them back to the Media Library page? Should we use the Referer header if present(passing it through wp_validate_redirect(), to make it safe) and if not, take them back to the Media Library page?

#16 @wonderboymusic
3 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

Edit Media screen is now an Edit Post screen since like 3.6

Note: See TracTickets for help on using tickets.