WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 6 years ago

Last modified 6 years ago

#7644 closed enhancement (duplicate)

Import Movable Type data using AtomPub.

Reported by: cavemonkey50 Owned by: westi
Milestone: Priority: normal
Severity: normal Version:
Component: Import Keywords:
Focuses: Cc:

Description

This is a split ticket from #7543. This includes the latest Movable Type portion of the code.

Attachments (2)

mt.diff (26.4 KB) - added by cavemonkey50 12 years ago.
The MT portion of the Atom importer.
atom.diff (57.0 KB) - added by cavemonkey50 12 years ago.
The shared Atom API library. If committing MT before TypePad, this should be included as well.

Download all attachments as: .zip

Change History (16)

@cavemonkey50
12 years ago

The MT portion of the Atom importer.

@cavemonkey50
12 years ago

The shared Atom API library. If committing MT before TypePad, this should be included as well.

#1 @westi
12 years ago

  • Owner changed from anonymous to westi
  • Status changed from new to assigned

How does this atom api compare to / co-exist with the atom code we already have?

Is this just a different implementation and extension of something different?

#2 follow-up: @cavemonkey50
12 years ago

From what I remember (it's been 2+ months since I worked on that portion), WSSE authentication was not working / non-existent in the current atom code and I didn't have an option to parse the tags I needed.

I remember that when looking at the Blogger importer it used a self-contained Atom parser since it needed to go above a beyond the current Atom API in WordPress.

#3 in reply to: ↑ 2 ; follow-up: @westi
12 years ago

Replying to cavemonkey50:

From what I remember (it's been 2+ months since I worked on that portion), WSSE authentication was not working / non-existent in the current atom code and I didn't have an option to parse the tags I needed.

I remember that when looking at the Blogger importer it used a self-contained Atom parser since it needed to go above a beyond the current Atom API in WordPress.

Ok. I think the blogger importer only has it's own Atom API as it existed before we supported APP - I have been meaning to see if they are the same code.

It would be best to only have one set of Atom classes if possible.

#4 in reply to: ↑ 3 @cavemonkey50
12 years ago

Replying to westi:

It would be best to only have one set of Atom classes if possible.

Yes, I agree. Let me know if there is anything I can do to help with that process.

#5 @westi
12 years ago

Cool. I've raised #7652 to cover the merging.

#6 @ryan
11 years ago

  • Milestone changed from 2.7 to 2.8

Moving enhancements to 2.8.

#7 @ryan
11 years ago

  • Milestone changed from 2.8 to 2.9

#8 @Denis-de-Bernardy
11 years ago

  • Keywords needs-patch added; gsoc needs-review removed
  • Milestone changed from 2.9 to Future Release

see #7652 and #10147

#9 @Denis-de-Bernardy
11 years ago

  • Keywords close added

@ron - shall we close this one as dup and put everything in 7652?

#10 @Denis-de-Bernardy
11 years ago

  • Component changed from Administration to Import

#11 @westi
10 years ago

Related tickets: #4555 (MT and TypePad) , #7543 (TypePad), #7652 - Merge all the differ atom libs we have.

#12 @SergeyBiryukov
9 years ago

  • Milestone changed from Future Release to WordPress.org

#13 @chriscct7
6 years ago

  • Resolution set to duplicate
  • Status changed from accepted to closed

Duplicate of #7652.

#14 @DrewAPicture
6 years ago

  • Keywords needs-patch close removed
  • Milestone WordPress.org deleted
Note: See TracTickets for help on using tickets.