WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#7667 closed defect (bug) (invalid)

Ooyala.com Flash Player fails to load in published WP Post pages being views in Internet Explorer (IE7)

Reported by: bigaqua Owned by:
Milestone: Priority: normal
Severity: major Version: 2.6.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

There are issues getting flash videos served by ooyala.com flash player embedded in WP (.org install) to play in all browsers. This may related to a more global issue with embedding some versions of flash players directly inside Wordpress posts. The issue is most pronounced with in IE7 (maybe IE6 too). Videos DO play in Firefox (all recent versions) on both windows and mac and Safari.

Two behaviors have been noted:

  1. player fails to load (this issue is most pronounced in Internet Explorer)

2 player preview image fails to load but the player still functions (this issue occurs randomly in all browsers tested)

The flash video failure occurs most consistently on "post" pages. I have been working on this for some time and have searched google and the WP codex. Ooyala.com is also aware but insists the problem is with the Wordpress coding. As an additional point of reference, the WP codex describes a javascript failure issue at: http://codex.wordpress.org/Using_Javascript - so this may or may not be a similar the area of concern.

Example page with the ooyala video embedded in a post is at:
http://woodtreks.com/use-a-smoothing-plane-for-the-perfect-finish/139/
(this sample embed is in a WP 2.6 install)

Note: To eliminate the possibility of plugin or theme variables or outdated WP version, I have a staging site where I have upgraded to 2.6.1, where all plugins are turned off and where the standard "classic" theme is running. The same IE player loading problem still persists. Please contact me directly if you need access to this staging area for testing.

Change History (4)

comment:1 jacobsantos5 years ago

  • Component changed from WordPress.org to TinyMCE
  • Keywords flash player embed Internet explorer load ooyala removed
  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Actually, it seems that the HTML should be supported by IE 7 and 6. It works using IE 8 by the way. Since it works in Firefox, it doesn't appear to be a WordPress issue.

Reopen if you find what the exact cause is. "They said..." isn't a valid report.

comment:2 jacobsantos5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:3 jacobsantos5 years ago

  • Owner matt deleted
  • Status changed from reopened to new

comment:4 jacobsantos5 years ago

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.