WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#7684 closed defect (bug) (fixed)

Google Chrome misreported as Safari in Turbo options

Reported by: Mr_Cynical Owned by: azaozz
Milestone: 2.8 Priority: lowest
Severity: trivial Version: 2.7
Component: Administration Keywords:
Focuses: Cc:

Description

When using the 'Turbo' option in the admin menu under Google Chrome, the browser is misreported as Safari (presumably because it uses the same WebKit base). It isn't a big deal as everything works fine, it's more of a cosmetic/polish issue caused by the browser sniffer being written before Chrome existed.

Attachments (1)

wp_gears_chrome.jpg (97.9 KB) - added by Mr_Cynical 7 years ago.
Cropped screenshot of the Turbo/Gears 'ajax popup' that has the fault

Download all attachments as: .zip

Change History (13)

@Mr_Cynical7 years ago

Cropped screenshot of the Turbo/Gears 'ajax popup' that has the fault

comment:1 @ryan7 years ago

  • Owner changed from anonymous to azaozz

comment:2 @azaozz7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [8815]) Add simple Chrome detection and updates for Gears dialog, fixes #7684

comment:3 follow-up: @caesarsgrunt7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I don't really like the language :

You can disable it from your browser’s Options, Under the Hood menu.

Right-oh. But hang on, where is this Hood menu my browser's options are Under? :)

I'd suggest

You can disable it from the "Under the Hood" section of your browser's Options.

or even better,

You can disable it from the "Under the Hood" section of Google Chrome's Options.

since Safari is referred to by name, why not Chrome?

comment:4 in reply to: ↑ 3 ; follow-up: @azaozz7 years ago

Replying to caesarsgrunt:

since Safari is referred to by name, why not Chrome?

Safari has a menu that called... Safari (on Mac) and the menu in Chrome has really no name at all, just an icon.

comment:5 in reply to: ↑ 4 @caesarsgrunt7 years ago

Replying to azaozz:

Safari has a menu that called... Safari (on Mac) and the menu in Chrome has really no name at all, just an icon.

Yes, alright. It is actually called the 'Google Chrome Menu', I wasn't referring to the menu. Anyway, I get your point.

How's the first suggestion then?

comment:6 @Speedboxer7 years ago

Why not just:

Gears is installed and enabled on this computer. You can disable it from Chrome's Tools > Options > Under the Hood dialog.

And yes, it is called the Tools menu (see here).

comment:7 @caesarsgrunt7 years ago

Not sure about that - whilst is is certainly clear and understandable, it's not technically corect as Under the Hood isn't a dialog, but a tab, or page of a dialog. (Also, should we mention the Gears Settings dialog, which is the next step? Or are we assuming that's obvious?)

And yes, you're right, it's the Tools menu not the Chrome menu. Sorry... (But as said, I wasn't actually referring to the menu.)

comment:8 follow-up: @Speedboxer7 years ago

  • Milestone set to 2.7
  • Version set to 2.7

Yes, but the whole thing is a dialog box. As for mentioning "Change Google Gears Settings", we don't mention anything like that for the other browsers, so I don't think it's necessary here. We could also link to that Google Help Article, which could provide users with more details.

Something like:

Gears is installed and enabled on this computer. You can disable it from Chrome's Tools > Options > Under the Hood dialog. For more details on disabling Gears, please see Google's help article.

comment:9 in reply to: ↑ 8 @caesarsgrunt7 years ago

Replying to Speedboxer:

Yes, but the whole thing is a dialog box.

Yes, but "Chrome's Tools > Options > Under the Hood dialog" means that Under the Hood is a dialog, which it isn't. (Actually I'm not sure that Options is even a dialog. Isn't it an options panel? Or is that Mac terminology?)
Maybe I'm being too pedantic, but I do think we should use correct terminology.

I don't think it's really necessary to mention the Tools menu - most people know how to open their browser's Options or can easily work out how.
Also, saying "Tools > Options > Under the Hood" implies nested menus, since that is the syntax normally used for describing menu actions.

How about

Gears is installed and enabled on this computer. You can disable it from the Under the Hood tab in Chrome's Options panel. For more details, please see Google's help page.


As for mentioning "Change Google Gears Settings", we don't mention anything like that for the other browsers, so I don't think it's necessary here.

No, maybe not. Or maybe it should mention it for the other browsers too. But it's probably OK without.

We could also link to that Google Help Article, which could provide users with more details.

Yes, good idea. I have done so in my suggested text, above.

comment:10 @janeforshort7 years ago

  • Milestone changed from 2.7 to 2.9

comment:11 @azaozz6 years ago

  • Milestone changed from 2.9 to 2.8

comment:12 @azaozz6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [10746]) Better Google Chrome "Disable Gears" message, props caesarsgrunt, fixes #7684

Note: See TracTickets for help on using tickets.