WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7722 closed defect (bug) (worksforme)

HTTP API: Streams, Warnings on post failure

Reported by: DD32 Owned by: jacobsantos
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: reporter-feedback
Focuses: Cc:

Description

Error messages and useless stack trace:

( ! ) Notice: fopen() [function.fopen]: send of 8192 bytes failed with errno=10035 A non-blocking socket operation could not be completed immediately. in C:\www\wordpress\wp-includes\http.php on line 745
Call Stack
#	Time	Memory	Function	Location
1	0.0361	249648	{main}( )	..\plugins.php:0
2	0.0370	315824	require_once( 'C:\www\wordpress\wp-admin\admin.php' )	..\plugins.php:10
3	0.5622	15039272	do_action( )	..\admin.php:126
4	0.5625	15040952	call_user_func_array ( )	..\plugin.php:339
5	0.5625	15040952	wp_update_plugins( )	..\plugin.php:0
6	0.8338	15197520	wp_remote_request( )	..\update.php:151
7	0.8346	15197736	WP_Http->request( )	..\http.php:1050
8	0.8350	15199664	WP_Http_Streams->request( )	..\http.php:227
9	0.8354	15234880	fopen ( )	..\http.php:745


( ! ) Warning: fopen(http://api.wordpress.org/plugins/update-check/1.0/) [function.fopen]: failed to open stream: HTTP request failed! in C:\www\wordpress\wp-includes\http.php on line 745
Call Stack
#	Time	Memory	Function	Location
1	0.0361	249648	{main}( )	..\plugins.php:0
2	0.0370	315824	require_once( 'C:\www\wordpress\wp-admin\admin.php' )	..\plugins.php:10
3	0.5622	15039272	do_action( )	..\admin.php:126
4	0.5625	15040952	call_user_func_array ( )	..\plugin.php:339
5	0.5625	15040952	wp_update_plugins( )	..\plugin.php:0
6	0.8338	15197520	wp_remote_request( )	..\update.php:151
7	0.8346	15197736	WP_Http->request( )	..\http.php:1050
8	0.8350	15199664	WP_Http_Streams->request( )	..\http.php:227
9	0.8354	15234880	fopen ( )	..\http.php:745

Env: Windows XP SP2 + Apache 2 + PHP5ish

Change History (6)

comment:1 jacobsantos6 years ago

Well, hmm, I suppose we could try blocking mode and see if that works. I'm not exactly sure what could have caused the failure. However, I have received similar errors before.

comment:2 jacobsantos6 years ago

  • Keywords reporter-feedback added

Any more information on what the problem is or possible fix? I would like to see this corrected.

comment:3 jacobsantos6 years ago

  • Owner changed from anonymous to jacobsantos
  • Status changed from new to assigned

comment:4 DD326 years ago

It hasnt happened again, I suspect it may have been caused by my ADSL droping out mid-connection.

Errors should be prevented from appearing if WP is installed in an offline situation, such as a intranet though.

comment:5 jacobsantos6 years ago

Well, I think it is strange, since unless WP_DEBUG is turned on, fopen shouldn't send any notices or warnings.

comment:6 jacobsantos6 years ago

  • Milestone 2.7 deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

Need more information before continuing. Reopen if more information becomes available.

Note: See TracTickets for help on using tickets.