WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 16 months ago

#7730 closed enhancement (duplicate)

The User Edit screen could have more classes on the HTML

Reported by: simonwheatley Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6.1
Component: UI Keywords: has-patch gsoc
Focuses: Cc:

Description

Given a more liberal sprinkling of classes through the WP admin interface, plugins could highlight different areas, hide unwanted form fields easily, etc. Currently you have to use something like jQuery in order to find and address fields that you want to hide.

The attached patch adds lots of semantically appropriate classes to the user edit screen, so plugin authors of the future can use CSS rather than resorting to Javascript. The patch is created against 2.6.2.

Attachments (2)

user-edit-classes.diff (5.1 KB) - added by simonwheatley 6 years ago.
Patch to add classes to the user edit screen
7730.diff (5.7 KB) - added by wojtek.szkutnik 4 years ago.

Download all attachments as: .zip

Change History (7)

simonwheatley6 years ago

Patch to add classes to the user edit screen

comment:1 janeforshort6 years ago

  • Milestone changed from 2.7 to 2.9

comment:2 Denis-de-Bernardy5 years ago

  • Component changed from General to UI
  • Owner anonymous deleted

comment:3 Denis-de-Bernardy5 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone changed from 2.9 to Future Release

wojtek.szkutnik4 years ago

comment:4 wojtek.szkutnik4 years ago

  • Cc wojtek.szkutnik@… added
  • Keywords has-patch gsoc added; needs-patch removed

comment:5 helen16 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Marking as a duplicate of #12295, which has been milestoned and has some more discussion.

Note: See TracTickets for help on using tickets.