Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7736 closed defect (bug) (duplicate)

Solution to mod_security issue with Insert Into Post for Media

Reported by: kaota Owned by:
Milestone: Priority: high
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:


After some head banging and keeping up with many threads on the forums regarding what to do about the problem mod_security presents with the "Insert Into Post" button for media, I went out to solve the problem myself. After some digging, it occurred to me that the button itself is the problem. Many mod_security configurations deny anything that looks like SQL, and yep, "INSERT INTO" is "SQL". I tried changing all occurances of this in wp-admin/media.php to something else, like "Put inside post" and it actually worked!

I suggest renaming the button so that fewer people will have to work around this issue.

Change History (2)

#1 @kaota
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

I see this was already reported, closing.

#2 @thee17
7 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.