WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 6 years ago

Last modified 13 months ago

#7754 closed defect (bug) (duplicate)

texturize bug with quotes inside parenthesis

Reported by: markjaquith Owned by: markjaquith
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Formatting Keywords: wptexturize needs-patch
Focuses: Cc:

Description

I waved to a friend ("hi there!" he said).

Becomes:

I waved to a friend (”hi there!” he said).

That first quote should be an open quote, not a close quote.

Attachments (1)

7754.001.diff (1.3 KB) - added by markjaquith 8 years ago.

Download all attachments as: .zip

Change History (13)

@markjaquith
8 years ago

#1 @markjaquith
8 years ago

  • Keywords has-patch needs-testing added
  • Owner changed from anonymous to markjaquith
  • Status changed from new to assigned

Patch uploaded. Needs to be tested for regressions.

#2 @markjaquith
7 years ago

  • Milestone changed from 2.7 to 2.8

Punting.

#4 @designsimply
7 years ago

Here's a similar instance:

's'
becomes
’s’
but it should be
‘s’
http://img.skitch.com/20090218-e5w6144tru1wfejr9h59uws2h6.png

#5 @ryan
7 years ago

  • Component changed from General to Formatting

#6 @Denis-de-Bernardy
7 years ago

("foo") without a leading space doesn't get caught using that, does it?

#7 @Denis-de-Bernardy
7 years ago

  • Keywords needs-patch added; has-patch needs-testing removed
  • Milestone changed from 2.8 to Future Release

patch is b0rke

#8 @Denis-de-Bernardy
7 years ago

  • Milestone changed from Future Release to 2.9

#9 @voyou1
7 years ago

I believe this bug is a duplicate of #1418.

#10 @designsimply
7 years ago

  • Cc designsimply added

#11 @markjaquith
6 years ago

  • Resolution set to duplicate
  • Status changed from accepted to closed

Looks like a duplicate of #1418. Closing.

#12 @DrewAPicture
13 months ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.