WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#7762 closed defect (bug) (worksforme)

do_action( 'sidebar_admin_page' ) in widgets.php in the wrong place?

Reported by: petervanderdoes Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Widgets Keywords: reporter-feedback
Focuses: Cc:

Description

When an action is added to the sidebar_admin_page the result of the do_action messes up the page.

The result is an entire page that is inaccessible except for the code added through the add_action.

By moving line 328 in wp-admin/widgets.php to line 294 the problem is solved.

Attachments (1)

patch.txt (416 bytes) - added by petervanderdoes 6 years ago.
Patch to solve the problem

Download all attachments as: .zip

Change History (6)

petervanderdoes6 years ago

Patch to solve the problem

comment:1 ryan5 years ago

  • Component changed from Administration to Widgets
  • Owner anonymous deleted

comment:2 Denis-de-Bernardy5 years ago

  • Keywords reporter-feedback added
  • Milestone set to 2.9

could you be more specific? the hook seems to be at the correct location as it currently is...

comment:3 Denis-de-Bernardy5 years ago

  • Milestone changed from 2.9 to 2.8

see also #9511

comment:4 Denis-de-Bernardy5 years ago

  • Milestone changed from 2.8 to Future Release

comment:5 Denis-de-Bernardy5 years ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

tried it and nothing gets messed up

Note: See TracTickets for help on using tickets.