WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 6 days ago

#777 closed defect (bug) (fixed)

Paragraphs not added

Reported by: anonymousbugger Owned by: ryan
Milestone: Priority: normal
Severity: major Version: 1.5
Component: Administration Keywords:
Focuses: Cc:

Description

Paragraph tags are not added for plain-text entries. This messes up the output and leaves entire entries as a single paragraph.

They were being created before 1.5-beta-1 2005-02-01.

No other plugins are being used.

Attachments (1)

applyfilter_functions.diff (584 bytes) - added by anonymousbugger 10 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 @anonymousbugger10 years ago

  • Patch set to No

comment:2 @DarkCryst10 years ago

from hacking around with the code it apears that wpautop() isn't being called.

I changed the function to output just "beans".. gues what? No beans.

comment:3 @DarkCryst10 years ago

confirmed now: wpauto is NOT being called in the filter list. I've not confirmed what other filters are being called or not. Plugins seem to be working.

tested this by editing the content()

$content = get_the_content($more_link_text, $stripteaser, $more_file);
$content = apply_filters('the_content', $content);
$content = str_replace(']]>', ']]>', $content);
echo $content;

becomes this:

$content = get_the_content($more_link_text, $stripteaser, $more_file);
$content = apply_filters('the_content', $content);
$content = wpautop($content);
$content = str_replace(']]>', ']]>', $content);
echo $content;

and it works fine. Obviously some flaw in the filters. This, of course, NOT a patch. Its a stopgap test measure.

comment:4 @DarkCryst10 years ago

confirmed that no filters for "the_content" are being applied. Does not convert smileys or special characters.

Obviously this is pretty serious.

comment:5 @pbannister10 years ago

I am seeing the same thing here, on a site run directly out of CVS. Reverting to "yesterday" removes the formatting problem:

cvs up -D yesterday

So clearly this was caused by one of the (many) recent changes. Will see if I cannot narrow the time window down some...

comment:6 @pbannister10 years ago

The problem was introduced between 6:20am and 6:25am GMT. You can see the changes in that time with:

cvs diff -D '2/1 6:20am GMT' -D '2/1 6:25am GMT'

Presumably the change in wp-includes/functions.php are the cause.

comment:7 @coffee2code10 years ago

I believe in the function apply_filters(), $args needs to be set within the innermost foreach(), otherwise the $string modified by each filter function won't be passed to subsequent filter functions.

A quick test seemed to suggest the attached patch -- applyfilters_functions.diff, run against wp-includes/functions.php v1.246 -- fixes the problem.

comment:8 @coffee2code10 years ago

  • Owner changed from anonymous to rboren
  • Patch changed from No to Yes
  • Status changed from new to assigned

comment:9 @ryan10 years ago

  • fixed_in_version set to 1.5
  • Resolution changed from 10 to 20
  • Status changed from assigned to closed

comment:10 @ircbot15 months ago

This ticket was mentioned in IRC in #wordpress-ui by helen. View the logs.

comment:11 @slackbot2 weeks ago

This ticket was mentioned in Slack in #design by celloexpressions. View the logs.

comment:12 @slackbot6 days ago

This ticket was mentioned in Slack in #design by celloexpressions. View the logs.

Note: See TracTickets for help on using tickets.