Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7776 closed defect (bug) (worksforme)

Comment author it is not displayed if it contains a special character

Reported by: moikirsch Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6.1
Component: General Keywords: comment author
Focuses: Cc:


The function that returns the comment autor doesn't work properly if the name contains a special character (such as ñ).

The name is ok in the database so it's a defect caused on the frontend side.

It also affects the tag that displays the comment author.

Change History (4)

#1 @DD32
7 years ago

Works for me.

IMO, The problem is going to be with the Charset used by your database vs. the charset you've got WordPress talking to the database with.

See #7683 and links within

#2 @moikirsch
7 years ago

One thing is to displayed the wrong character... but on this case it is not displaying anything at all (not just the character but the whole name).

#3 @DD32
7 years ago

Well... Thats odd, I still suggest you look into the charsets though, It worked for me.

#4 @Denis-de-Bernardy
7 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

works for me too, in 2.8

Note: See TracTickets for help on using tickets.