WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7800 closed defect (bug) (fixed)

Theme Directory page broken

Reported by: thee17 Owned by:
Milestone: 2.7 Priority: normal
Severity: critical Version: 2.7
Component: Administration Keywords:
Focuses: Cc:

Description

Using r9017 In /wp-admin/themes.php

Current Theme
by

All of this theme’s files are located in .

Fatal error: Cannot use object of type stdClass as array in /home/thee17/public_html/cefmdottv/wp-admin/themes.php on line 69

Attachments (1)

7800.diff (597 bytes) - added by DD32 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 DD326 years ago

I'm suspicious as to why the error has appeared now that the theme update stuff is in; Its caused by the Theme update checkers UI not checking the type first, But the fact your current theme doesnt have a valid stylesheet name assoc. with it, seems to say there's something else at fault (perhaps in your setup).

I would add a var_dump($theme); to line #66 of wp-admin/themes.php to check that the result from current_theme_info() is correct. eg:

	if ( !isset($themes_update) )
		$themes_update = get_option('update_themes');
var_dump($theme);
	if ( isset($theme->stylesheet) )
		$stylesheet = $theme->stylesheet;

DD326 years ago

comment:2 DD326 years ago

That patch adds type-checking to the function as well as just checking if the element is set.

comment:3 thee176 years ago

My Current theme's CSS's header is as follows. I noticed from going from r8998 to r9017 did not upgrade btween them, it is happining on 2 installs that happen to use the same theme the other replaces .ca with .tv

/*

Theme Name: CEFM.ca ver 3.1 was communist

Description: 2 coloumn red web2 theme

Author: Jinsona designs

Author URI: http://web2feel.com/

Tags: 2 coloumn red web2 theme

*/

comment:4 thee176 years ago

Tried the patch and it fixed the problem.

comment:5 DD326 years ago

The patch will hide the error, But in my mind, The problem is that its making it to that point, Knowing what the $theme is set to when it fails would be helpful. As it is, Your current theme would not be checked to see if there was an updated version available, Even if it was listed in the directory.

comment:6 thee176 years ago

There was no current theme (apparently) since i changed the version via ftp to 3.1 from 3.0.1. Is there a tag to have the verson not in the name?

comment:7 thee176 years ago

I found it.
Version: 3.1.1

comment:8 ryan6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9227]) Add some type sanity checks. Props DD32. fixes #7800

Note: See TracTickets for help on using tickets.