Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#7809 closed defect (bug) (worksforme)

Blogger Import Stops Prematurely

Reported by: covert215 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7.1
Component: Import Keywords: reporter-feedback
Focuses: Cc:


When importing a blog from Blogger, the process stops after prematurely. The "Magic Button" changes to "Set Authors." The importer recognizes all posts and comments but fails to load them.

The status bar shows that 49/570 posts and 50/118 posts are successfully imported. Upon examination, there is nothing out of the ordinary about the posts that cause the importer to stall.

Change History (8)

#1 @covert215
7 years ago

*50/118 comments

#2 @thesethings
7 years ago

Just wanted to add, that I went back and tested import-from-Blogger in 2.5.x and 2.3.x, just to control for it being something in 2.6.x None of them worked. So this might be a change in the Google Blogger API. In the past this has broken when they changed a hostname.

#3 @covert215
7 years ago

This bug is affecting WordPress.com sites too, so its not a hosting configuration issue.

#4 @covert215
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Everything seems to be working now...

#5 @jacobsantos
7 years ago

  • Milestone 2.8 deleted

#6 @JacquesChester
7 years ago

  • Cc JacquesChester added
  • Component changed from Administration to Import
  • Keywords blogger import stalls set author added
  • Milestone set to 2.7.2
  • Priority changed from normal to high
  • Resolution fixed deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened
  • Version set to 2.7.1

I am proposing this bug be reopened. The issue is not resolved.

  • I log in to a new wordpress install.
  • Select Import / Blogger
  • Do the authorisation
  • Import starts. 1/1594 posts and 1/8085 comments imported, then it stalls.
  • Go to a different admin page, then click back to Import / Blogger
  • Shows "Set Authors" button.
  • Get the table for mapping. Nothing under "Blogger username". Dropdown list under "WordPress login".
  • Press "Save Changes"
  • Get redirected to listing of posts already on Wordpress install (ie, made in Wordpress, not imported)
  • Go back to Blogger / Import. "Set Authors" button still there, no import progress.

#7 @Denis-de-Bernardy
7 years ago

  • Keywords reporter-feedback added; blogger import stalls set author removed
  • Milestone changed from 2.7.2 to 2.9
  • Priority changed from high to normal
  • Severity changed from major to normal

the import file would be useful to reproduce...

#8 @ryan
6 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Closing pending requested feedback.

Note: See TracTickets for help on using tickets.