WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7812 closed enhancement (invalid)

What about upgrade instructions on plugin auto upgrade?

Reported by: whoismanu Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

currently as a plugin developer i have no means of passing upgrade instructions to my users if they use the wordpress auto upgrade feature. what about having a message display, saying that there are upgrade instructions for this plugin to be read before performing the auto update?

i could imagine the upgrade instructions being a section of the wordpress plugin directory readme.txt file. if the section is present, it is displayed (or at least a message is shown saying that there are instructions) otherwise the auto update is directly performed assuming that there are no upgrade instructions.

Change History (4)

comment:1 jacobsantos6 years ago

This is a duplicate of another ticket. This ticket will be closed.

Recommendation: Don't place user edited files in your plugin directory and use the wp-content folder instead. See other ticket for more discussion.

comment:2 DD326 years ago

In adition, WordPress 2.7 will have it read along the lines of: "An upgrade is available, View version 99.9 Details or upgrade automatically." The details link allows full viewing of the plugin details from the readme.txt (Basically what you see on wordpress.org/extend/plugins/plugin-name/ in the same format)

While it doesnt force users to visit the details link, You could add a note to the plugin description along the lines of "Upgrade note: Please view the Plugin details before performing an upgrade to view upgrade notes"

I'm not too sure there'll be a function to force users to view your upgrade instructions though, Same goes for preserving data files in the plugin directory.

comment:3 whoismanu6 years ago

thanks for the replies guys. and sorry for double posting on this issue, don't know how i couldn't see the other ticket, i even searched - well not well enough apparently.

jacobsantos: thanks for your recommendation, that is exactly what causes problems in my case and i already planned to do what you suggest for the next release. i still think there should be some guidelines on how to structure plugins on http://wordpress.org/extend/plugins/about/ to prevent problems like this in the first place.

DD32: that's good news and i think it is good enough (no need to force users to view it). since the last release my plugin has an upgrade note like the one you suggest, however i think that what you say will come in 2.7 is much cleaner. regarding storing files in the plugin directory, i now understand that this is bad practice and should not be done, however, the plugin authors should be made aware of this, see my answer to jacobsantos above.

comment:4 DD326 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Sounds like the current implementation in 2.7 of having a details popup would be acceptable.

Note: See TracTickets for help on using tickets.