WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7815 closed defect (bug) (fixed)

ampersand should not be escaped in rss feed category cdata?

Reported by: username2 Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

I have a category named R&D. In feed view of IE8 (and 7?), the category is rendered as R&D. The feed xml for the category looks like:

<title>Updated WordPress to 2.6.2</title>
<link>http://example.com/wordpress/?p=7</link>
<comments>http://example.com/wordpress/?p=7#comments</comments>
<pubDate>Sun, 28 Sep 2008 08:34:37 +0000</pubDate>
<dc:creator>admin</dc:creator>


<category><![CDATA[R&amp;D]]></category>

I believe <category><![CDATA[R&amp;D]]></category> should be <category><![CDATA[R&D]]></category> or <category>R&amp;D</category>.

Change History (3)

comment:1 lloydbudd6 years ago

I believe this is a duplicate of #4321

comment:2 matt6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9148]) Don't encoded category element contents - fixes #4321 and #7815.

comment:3 thee176 years ago

  • Milestone changed from 2.8 to 2.7
Note: See TracTickets for help on using tickets.