Make WordPress Core

Opened 19 years ago

Closed 19 years ago

#783 closed defect (bug) (fixed)

[Dashboard] Upcoming posts show GMT timediff instead of local timediff

Reported by: sethkinast's profile sethkinast Owned by: matt's profile matt
Milestone: Priority: normal
Severity: minor Version: 1.5
Component: Administration Keywords:
Focuses: Cc:

Description

If I create a post and set it to a time in the future, Dashboard shows me when the post will appear. However, it shows when the post will appear with relation to GMT, rather than respecting my local timezone.

One solution (diff attached) is to *subtract* the offset from time() since it is being passed as the leftside argument to human_time_diff().

Attachments (1)

index.php.diff (871 bytes) - added by sethkinast 19 years ago.

Download all attachments as: .zip

Change History (6)

#1 @sethkinast
19 years ago

  • Patch set to No

#2 @anonymousbugger
19 years ago

Isn't that expected behavior? It seems to display everything in UTC times.

#3 @sethkinast
19 years ago

I surely wouldn't think so, or at least that is not intuitive. I pre-posted a post to show up at midnight today; my offset is GMT -6. At 11:00 p.m. the Dashboard informed me my post would appear in 7 hours. Nope, 1 :)

#4 @CarLBanks
19 years ago

I also get this error.

#5 @matt
19 years ago

  • fixed_in_version set to 1.5
  • Owner changed from anonymous to matt
  • Resolution changed from 10 to 20
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.