WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#7865 closed defect (bug) (fixed)

Tag templates no longer work with tag-{$tag_name}

Reported by: cogmios Owned by: westi
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.7
Component: Template Keywords: tag template regression
Focuses: Cc:

Description (last modified by westi)

Tag template pages e.g. "tag-wordpress.php" to not be called or found. See http://edward.de.leau.net/tag-pages-and-wordpress-27-20081011.html.

I dont know the status of the function so I consider this a unit test report, but a pretty large bug.

Change History (4)

comment:1 westi6 years ago

  • Keywords needs-patch added
  • Owner changed from anonymous to westi
  • Priority changed from high to normal
  • Severity changed from major to normal
  • Status changed from new to assigned

Nothing is wrong with locate_template.

The fact is that the code in 2.6.x allows for textual tag templates 2.7 for some reason expects them to be numeric tag ids.

The change is in get_tag_template() which now wraps an absint around the result of get_query_var

comment:2 westi6 years ago

  • Description modified (diff)
  • Summary changed from new locate_template function causes TAG pages to NOT appear to Tag templates no longer work with tag-{$tag_name}

comment:3 westi6 years ago

  • Keywords regression added; needs-patch removed

Looks like that absint was an accidental copy and paste error when I did [8624]

comment:4 westi6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [9125]) Fix regression in get_tag_template(). Tag templates are referenced by tag name not id. Fixes #7865.

Note: See TracTickets for help on using tickets.